IBM Mainframe Forum Index
 
Log In
 
IBM Mainframe Forum Index Mainframe: Search IBM Mainframe Forum: FAQ Register
 

Getting message while using xped.


IBM Mainframe Forums -> Compuware & Other Tools
Post new topic   Reply to topic
View previous topic :: View next topic  
Author Message
vijay korde

New User


Joined: 19 Feb 2010
Posts: 27
Location: India

PostPosted: Mon Dec 06, 2010 5:43 pm
Reply with quote

Hello,

I am getting below message while using Xped. Can anybody share the info about it?

NO STANDARD RETURN LINKAGE FOUND FOR BREAKPOINT

Many thanks in advance.

-Vijay
Back to top
View user's profile Send private message
Anuj Dhawan

Superior Member


Joined: 22 Apr 2006
Posts: 6250
Location: Mumbai, India

PostPosted: Mon Dec 06, 2010 9:03 pm
Reply with quote

Some more information please. What did you do, when this happened? Was there some message identifier? What were you debugging using xpeditor - online or batch?
Back to top
View user's profile Send private message
vijay korde

New User


Joined: 19 Feb 2010
Posts: 27
Location: India

PostPosted: Tue Dec 07, 2010 11:18 am
Reply with quote

Thank you Anuj for the reply.

I wanted to trace module which is getting called from the source module. The called module is dynamically loaded in the calling module and called with BASR.

The calling module has AMODE/RMODE as 24/24 and the called module has 31/24. When at the time of BASR, I am giving INT <called_module_ name>. After that the source for the called module is displayed with the message

NO STANDARD RETURN LINKAGE FOUND FOR BREAKPOINT

When I started tracing, control automatically returning back to the calling program(at NSI after BASR).

Thank you,
Vijay
Back to top
View user's profile Send private message
vijay korde

New User


Joined: 19 Feb 2010
Posts: 27
Location: India

PostPosted: Tue Dec 07, 2010 11:38 am
Reply with quote

[size=24]
Code:
Getting screen as below.

[size=7]----------------------------------------------------- XPEDITER/TSO - SOURCE ------------------------------------------------------
COMMAND ===>                                                                                                      SCROLL ===> 0007
                                          NO STANDARD RETURN LINKAGE FOUND FOR BREAKPOINT                                         
         ** END **    [/size]                                                                                                             
                                                                                                                                   
                                                                                                                                   
                                                                                                                                   
                                                                                                                                   
------   ------------------------------------ Before <Calling_pgm>:9331/AMODE 24 ----------------------------------------------------<> [/size][size=18][/size]
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic View Bookmarks
All times are GMT + 6 Hours
Forum Index -> Compuware & Other Tools

 


Similar Topics
Topic Forum Replies
No new posts Print out all lines with 'IBM' compil... CLIST & REXX 8
No new posts How to get the message id thats trigg... Java & MQSeries 0
No new posts VB file copy COBOL program gives erro... COBOL Programming 3
No new posts JESYSMSG Message Log JCL & VSAM 1
No new posts Getting error while xped JCL & VSAM 10
Search our Forums:

Back to Top