IBM Mainframe Forum Index
 
Log In
 
IBM Mainframe Forum Index Mainframe: Search IBM Mainframe Forum: FAQ Register
 

JCL JOB Cancel/Purge Not Working


IBM Mainframe Forums -> JCL & VSAM
Post new topic   Reply to topic
View previous topic :: View next topic  
Author Message
DonnaClark

New User


Joined: 30 Jun 2021
Posts: 4
Location: United States

PostPosted: Wed Jun 30, 2021 5:31 am
Reply with quote

Hello,

Brand new to Mainframe and trying to work through, what should be simple, exercises.

A Dataset was not showing cataloged then I realized that it's still "Executing" in the Job Status.

I've tried entering P to the left of the job, I've tried CANCEL (name) PURGE

I logoff and back on again - it's still there. I get a message during the logon procedure. It's attached.

I'm not sure what to try next - any suggestions?

Thanks.
Back to top
View user's profile Send private message
Joerg.Findeisen

Active Member


Joined: 15 Aug 2015
Posts: 607
Location: Bamberg, Germany

PostPosted: Wed Jun 30, 2021 9:59 am
Reply with quote

Basically you have not read the descriptions on screen. Wait for the READY prompt first.

PS: Do NOT post attachments here.
Back to top
View user's profile Send private message
Pedro

Global Moderator


Joined: 01 Sep 2006
Posts: 2258
Location: Silicon Valley

PostPosted: Wed Jun 30, 2021 10:54 am
Reply with quote

Perhaps the batch job is also waiting for that data set. Perhaps someone else is also using TSOZA42.ES10.EXEC and neither you nor the batch job are able to allocate it.
Back to top
View user's profile Send private message
Joerg.Findeisen

Active Member


Joined: 15 Aug 2015
Posts: 607
Location: Bamberg, Germany

PostPosted: Wed Jun 30, 2021 1:53 pm
Reply with quote

That can probably be seen in SDSF (JY - Job Delay). But better you wait the 15 seconds that were promised to you by some of your Sysprogs. In case you have granted RACF rights, use D GRS command or the ENQ/ENQC command of SDSF.
Back to top
View user's profile Send private message
David Robinson

Active User


Joined: 21 Dec 2011
Posts: 199
Location: UK

PostPosted: Wed Jun 30, 2021 7:30 pm
Reply with quote

In 3.4, you can try to edit the dataset. If it's in use, you will get a message telling you that you cannot.

Press PF1 twice, and it will show you what else is using it, and hence why you cannot.
Back to top
View user's profile Send private message
DonnaClark

New User


Joined: 30 Jun 2021
Posts: 4
Location: United States

PostPosted: Wed Jun 30, 2021 8:37 pm
Reply with quote

Thanks for all your help - I modified things that I shouldn't have and got myself into a situation that I didn't have permission to fix. I've now got it sorted.

Thanks for the PF1 tip. I'm in the middle of the firehose and am loving the learning. I appreciate any help to get me through.
Back to top
View user's profile Send private message
Joerg.Findeisen

Active Member


Joined: 15 Aug 2015
Posts: 607
Location: Bamberg, Germany

PostPosted: Wed Jun 30, 2021 10:44 pm
Reply with quote

David Robinson wrote:
In 3.4, you can try to edit the dataset. If it's in use, you will get a message telling you that you cannot.

Press PF1 twice, and it will show you what else is using it, and hence why you cannot.

If you have MIM and GRS running for some reasons, you will not always see what is going on.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic View Bookmarks
All times are GMT + 6 Hours
Forum Index -> JCL & VSAM

 


Similar Topics
Topic Forum Replies
No new posts OMVS Shell Script not working properly. All Other Mainframe Topics 1
No new posts FSET not working on my receive CICS 3
No new posts Mainframe jcl job with href links not... All Other Mainframe Topics 3
No new posts On a team working on a new project fo... All Other Mainframe Topics 2
No new posts How efficient are you, while working ... General Talk & Fun Stuff 0
Search our Forums:

Back to Top