IBM Mainframe Forum Index
 
Log In
 
IBM Mainframe Forum Index Mainframe: Search IBM Mainframe Forum: FAQ Register
 

Getting error while xped


IBM Mainframe Forums -> JCL & VSAM
Post new topic   Reply to topic
View previous topic :: View next topic  
Author Message
tarakant82

New User


Joined: 27 Jul 2018
Posts: 4
Location: Pune

PostPosted: Tue Dec 01, 2020 10:02 am
Reply with quote

I am getting an error while doing xped
Code:
IEF237I JES2 ALLOCATED TO XPIN
ACF04056 ACCESS TO RESOURCE XPDTR002 TYPE RSAF BY MY-ID NOT AUTHORIZED
IEA995I SYMPTOM DUMP OUTPUT
  USER COMPLETION CODE=3398
 TIME=22.16.19  SEQ=09148  CPU=0000  ASID=01F8
 PSW AT TIME OF ERROR  078D1000   800153AC  ILC 2  INTC 0D
   ACTIVE MODULE           ADDRESS=00000000_00015000  OFFSET=000003AC


Can someone please help me why i am getting this error?

Code tags added for you - please do it yourself next time
Back to top
View user's profile Send private message
Nic Clouston

Global Moderator


Joined: 10 May 2007
Posts: 2455
Location: Hampshire, UK

PostPosted: Tue Dec 01, 2020 2:20 pm
Reply with quote

Try reading the messages - in particular the one beginning ACF.
And what is 'xped'?
Back to top
View user's profile Send private message
tarakant82

New User


Joined: 27 Jul 2018
Posts: 4
Location: Pune

PostPosted: Tue Dec 01, 2020 3:05 pm
Reply with quote

XPED - XPEDITOR debugging tool in MAinframe to debug the code line by line
Back to top
View user's profile Send private message
Garry Carroll

Senior Member


Joined: 08 May 2006
Posts: 1100
Location: Dublin, Ireland

PostPosted: Tue Dec 01, 2020 3:10 pm
Reply with quote

tarakant82 wrote:
XPED - XPEDITOR debugging tool in MAinframe to debug the code line by line



... and in what world is a debugging tool either JCL or VSAM ??

Garry.
Back to top
View user's profile Send private message
tarakant82

New User


Joined: 27 Jul 2018
Posts: 4
Location: Pune

PostPosted: Tue Dec 01, 2020 4:28 pm
Reply with quote

JCL, i think you never use this tool
Back to top
View user's profile Send private message
Garry Carroll

Senior Member


Joined: 08 May 2006
Posts: 1100
Location: Dublin, Ireland

PostPosted: Tue Dec 01, 2020 4:33 pm
Reply with quote

tarakant82 wrote:
JCL, i think you never use this tool


Well, you think incorrectly. I have been using XPED for a couple of decades and, while there may be JCL associated with it, it is most certainly NOT considered to be JCL.

Garry.
Back to top
View user's profile Send private message
Nic Clouston

Global Moderator


Joined: 10 May 2007
Posts: 2455
Location: Hampshire, UK

PostPosted: Tue Dec 01, 2020 7:21 pm
Reply with quote

Xpediter is a tool from Compuware. However, your error is not an Xpediter error nor a JCL error but a security error so that is where you should have posted.I will leave this here for the moment.
Back to top
View user's profile Send private message
steve-myers

Active Member


Joined: 30 Nov 2013
Posts: 870
Location: The Universe

PostPosted: Tue Dec 01, 2020 7:29 pm
Reply with quote

As Nic says, the ACF04056 message indicates some sort of security error. Evidently (from the text of the message) you are not authorized to use XPED. This is a matter you must discuss this with your support. No one in this forum can help you.
Back to top
View user's profile Send private message
sergeyken

Active Member


Joined: 29 Apr 2008
Posts: 957
Location: Maryland

PostPosted: Wed Dec 02, 2020 12:20 am
Reply with quote

tarakant82 wrote:
JCL, i think you never use this tool

Quote:
Everything not related to COBOL is supposed to be JCL
icon_fU.gif
Back to top
View user's profile Send private message
Rohit Umarjikar

Global Moderator


Joined: 21 Sep 2010
Posts: 2588
Location: NYC,USA

PostPosted: Wed Dec 02, 2020 4:08 am
Reply with quote

Quote:
ACF04056 ACCESS TO RESOURCE XPDTR002 TYPE RSAF BY MY-ID NOT AUTHORIZED
You need to double check in which region are you debugging and pick the right dev region and error should go away.
Once you are sure everything is correct and you still gets this error then talk to you site support group.
Back to top
View user's profile Send private message
tarakant82

New User


Joined: 27 Jul 2018
Posts: 4
Location: Pune

PostPosted: Wed Dec 02, 2020 10:23 am
Reply with quote

Thanks all, let me involve my support/security group, the same job was working till November 6 and since 30th November not working, so seems like access needs on this.

Thanks all to bring this up for my attention.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic View Bookmarks
All times are GMT + 6 Hours
Forum Index -> JCL & VSAM

 


Similar Topics
Topic Forum Replies
No new posts Secondary index error while loading d... IMS DB/DC 2
No new posts Error 0C1 Reason Code 1 with branch i... PL/I & Assembler 3
No new posts can someone please help me in finding... IBM Tools 9
No new posts SYNCSORT Error - CONTROL FIELD BEYOND... SYNCSORT 10
No new posts Easytrieve EZABX007 with error code 0... CA Products 7
Search our Forums:

Back to Top