IBM Mainframe Forum Index
 
Log In
 
IBM Mainframe Forum Index Mainframe: Search IBM Mainframe Forum: FAQ Register
 

Blue zone error with an invalid extended colour value


IBM Mainframe Forums -> CICS
Post new topic   Reply to topic
View previous topic :: View next topic  
Author Message
anslaan

New User


Joined: 12 Feb 2020
Posts: 2
Location: Australia

PostPosted: Wed Feb 12, 2020 9:21 am
Reply with quote

We are migrating from attachmate to rocket bluezone. One of the CICS screen is returning the error in a popup window - an sfe,sa or MF order was received with an invalid extended colour value . The error occurred at location 0xf in the write

The error is received upon any action on the screen , even just an ENTER key without entering any values in the screens. Basically when we call the program again after the screen is first received.

The same screen works without any issues in attachmate.

Checked the bluezone traces and can see the correct response is being returned by the program when hitting ENTER key (it is an error message to be displayed ).

Has anyone faced similar issues? Any leads appreciated.

Thank You!
Back to top
View user's profile Send private message
hankoerlemans

New User


Joined: 25 Jan 2018
Posts: 30
Location: Australia

PostPosted: Thu Feb 20, 2020 8:30 am
Reply with quote

If the emulator doesn't have an appropriate trace function then VTAM trace the 3270 flow and grab the 3270 books and go fer it.
Or the perhaps if PGM A works but PGM B does not you need to ask the author of PGM B ? i.e. Rocket ?
Back to top
View user's profile Send private message
anslaan

New User


Joined: 12 Feb 2020
Posts: 2
Location: Australia

PostPosted: Thu Feb 20, 2020 9:05 am
Reply with quote

Thank you @hankoerlemans

We took the trace later and Bluezone is finding issue at one particular
co-ordinate which happens to be the PageNo.

Apparently the pageno is not being handled well by the program as it goes blank when we just press ENTER. So might be some wrong attribute the program is pushing to it. We are checking further.

However, Bluezone has suggested a work around which worked indeed . In the session configuration Tick the box for "Ignore XProg Errors" .
Back to top
View user's profile Send private message
hankoerlemans

New User


Joined: 25 Jan 2018
Posts: 30
Location: Australia

PostPosted: Thu Feb 20, 2020 10:00 am
Reply with quote

Interesting approach. Coulda used that option over the last 30 or so years rather than the keyboard locking or blowing up my session ! icon_cool.gif
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic View Bookmarks
All times are GMT + 6 Hours
Forum Index -> CICS

 


Similar Topics
Topic Forum Replies
No new posts Secondary index error while loading d... IMS DB/DC 2
No new posts Error 0C1 Reason Code 1 with branch i... PL/I & Assembler 3
No new posts Getting error while xped JCL & VSAM 10
No new posts can someone please help me in finding... IBM Tools 9
No new posts SYNCSORT Error - CONTROL FIELD BEYOND... SYNCSORT 10
Search our Forums:

Back to Top