IBM Mainframe Forum Index
 
Log In
 
IBM Mainframe Forum Index Mainframe: Search IBM Mainframe Forum: FAQ Register
 

Undocumented ONCODE 8843?


IBM Mainframe Forums -> PL/I & Assembler
Post new topic   Reply to topic
View previous topic :: View next topic  
Author Message
Akatsukami

Global Moderator


Joined: 03 Oct 2009
Posts: 1788
Location: Bloomington, IL

PostPosted: Tue Nov 12, 2013 1:02 am
Reply with quote

Whilst testing a proof-of-concept program for converting IMS segments to XML, I got oncode 8843, apparently from a call to PLIFREE. This oncode does not seem to be documented in Enterprise PL/I for z/OS, Version 4.2, Messages and Codes (V4R2M0 is the version being run by my shop), nor does it appear to show up in a Bing search. Does anyone have a pointer to documentation for this oncode?
Back to top
View user's profile Send private message
Akatsukami

Global Moderator


Joined: 03 Oct 2009
Posts: 1788
Location: Bloomington, IL

PostPosted: Wed Nov 13, 2013 10:50 pm
Reply with quote

FYI: IBM suggsted that the oncode was bogus, produced by heap damage. I went over the code and found a buffer overrun; correcting caused the error to go away. Case closed.
Back to top
View user's profile Send private message
dick scherrer

Moderator Emeritus


Joined: 23 Nov 2006
Posts: 19245
Location: Inside the Matrix

PostPosted: Thu Nov 14, 2013 1:02 am
Reply with quote

Cool - good catch! Thanks icon_smile.gif

d
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic View Bookmarks
All times are GMT + 6 Hours
Forum Index -> PL/I & Assembler

 


Similar Topics
Topic Forum Replies
No new posts IBM0472S ONCODE=290 The INVALIDOP PL/I & Assembler 18
No new posts ONCODE=8094 from IRXLOAD CLIST & REXX 8
No new posts PLI RUN MESSAGE:ONCODE=8097 ABENDS & Debugging 5
No new posts Pl/1 oncode 310 PL/I & Assembler 12
No new posts ONCODE 310 FIXED DECIMAL OVERFLOW PL/I & Assembler 11
Search our Forums:

Back to Top