IBM Mainframe Forum Index
 
Register
 
IBM Mainframe Forum Index Mainframe: Search Log in to check your private messages Log in
 

IOF not working from ISPF panel


IBM Mainframe Forums -> TSO/ISPF
Post new topic   Reply to topic
View previous topic :: View next topic  
Author Message
Balaji Krishnamurthy

New User


Joined: 26 Feb 2008
Posts: 20
Location: chennai

PostPosted: Thu Mar 25, 2010 8:23 pm
Reply with quote

I tried to type 'I' on the ISPF primary options menu. It shows up the following error.


"*" CAN ONLY APPEAR AS THE LAST CHARACTER IN A COMPARISON STRING


However, when I execute 'TSO IOF', i am able to see the IOF screen. But, it doesn't allow me to edit or re-submit jobs from IOF saying that the command is not a valid 'ISPF' command.

Any pointers to resolve this issue.
Back to top
View user's profile Send private message
enrico-sorichetti

Senior Member


Joined: 14 Mar 2007
Posts: 10697
Location: italy

PostPosted: Thu Mar 25, 2010 8:30 pm
Reply with quote

the best source of info would be Your support!
after all <They> did the <customization> and ISPF integration

if the thing works by typing on the command line TSO <something>
the product is installed,
if You expected to use it as a normal ISPF option, then the ISPF integration is missing
or has not be done properly
anyway see my first line of the reply
Back to top
View user's profile Send private message
Pedro

Global Moderator


Joined: 01 Sep 2006
Posts: 2206
Location: Silicon Valley

PostPosted: Fri Mar 26, 2010 12:33 am
Reply with quote

What is IOF?
Back to top
View user's profile Send private message
superk

Global Moderator


Joined: 26 Apr 2004
Posts: 4650
Location: Raleigh, NC, USA

PostPosted: Fri Mar 26, 2010 12:39 am
Reply with quote

Probably Interactive Output Facility from Triangle Systems.
Back to top
View user's profile Send private message
ignich7

New User


Joined: 02 Nov 2005
Posts: 66

PostPosted: Fri Dec 08, 2017 2:43 pm
Reply with quote

Am sorry, I know its a very old post.. but I reply anyway because I had the same error and was banging my head for almost 3 hrs to fix it.. and not much help from google.. so, just to save your time if you have same issue.

From ISPF primary options menu, instead of just "I", issue "IOF *" and it takes you to IOF. Now, you may want to double check your filters.

For me, the issue was, I had * specified in SCOPE. So when I issue "I" from ISPF primary options menu it thorws "*" CAN ONLY APPEAR AS THE LAST CHARACTER IN A COMPARISON STRING

Thanks.
Gnana Nicholas
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic View Bookmarks
All times are GMT + 6 Hours
Forum Index -> TSO/ISPF

 

Search our Forum:

Similar Topics
Topic Forum Replies
No new posts FSET not working on my receive CICS 3
No new posts How to setup MQ panel TSO/ISPF 3
No new posts Mainframe jcl job with href links not... All Other Mainframe Topics 3
No new posts ISPF Panel commands DDLIST /LISTBOX TSO/ISPF 11
No new posts Am Getting a vertical line in ISPF SC... TSO/ISPF 3

Back to Top