Portal | Manuals | References | Downloads | Info | Programs | JCLs | Mainframe wiki | Quick Ref
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Profile Log in to check your private messages Log in
 
endevor error

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> CA Products
View previous topic :: :: View next topic  
Author Message
siva1110

New User


Joined: 01 Sep 2007
Posts: 5
Location: singapore

PostPosted: Thu Sep 11, 2014 4:45 pm    Post subject: endevor error
Reply with quote

I have wrongly created dataset with length 800 instead of 80 so I am unable to add source element to endevor



I have deleted and recreated source dataset still I am getting same error.

DSN VALIDATION OPTION IS ACTIVE - ELEMENT MUST BE RETRIEVED PRIOR TO ADD/UPDATE
please let me know how to resolve this issue thanks all
Back to top
View user's profile Send private message

dbzTHEdinosauer

Global Moderator


Joined: 20 Oct 2006
Posts: 6968
Location: porcelain throne

PostPosted: Thu Sep 11, 2014 8:58 pm    Post subject:
Reply with quote

ELEMENT MUST BE RETRIEVED PRIOR
Back to top
View user's profile Send private message
dbzTHEdinosauer

Global Moderator


Joined: 20 Oct 2006
Posts: 6968
Location: porcelain throne

PostPosted: Thu Sep 11, 2014 9:21 pm    Post subject:
Reply with quote

the element exists in the endevor library.

so, you have to retrieve (check it out) prior to modification.

ask you supervisor how to to do this if you do not want to bother to read
the facility guides or instruction manual. as well as the endevor manual.

i assume you are working on a new module. It probably has a placeholder in endevor, since
creation of a new module
and
modification of an existing module
are two entirely different actions and require different authority.
Back to top
View user's profile Send private message
siva1110

New User


Joined: 01 Sep 2007
Posts: 5
Location: singapore

PostPosted: Fri Sep 12, 2014 10:52 am    Post subject:
Reply with quote

Hi Dickl

This is existing module in prod. I have retrieved from Prod only. but unable to add this element to endeavor.
Please let me know how to deactivate dsn validation option in endeavor. Thanks all
Back to top
View user's profile Send private message
Rohit Umarjikar

Senior Member


Joined: 21 Sep 2010
Posts: 1806
Location: NY,USA

PostPosted: Fri Sep 12, 2014 9:13 pm    Post subject:
Reply with quote

Code:
C1G0170E
 
DSN VALIDATION OPTION IS ACTIVE - ELEMENT MUST BE RETRIEVED PRIOR TO ADD/UPDATE
 
Reason:
 
The data set validation option is active for the current system. The element must be retrieved prior to updating, or the data set and/or member name of the retrieve data set is different than the name of the source data set and/or member.
 
Action:
 
Use the element master display panel to determine the location to which the element was retrieved. Make sure this matches the name of the source location you are specifying when executing the Add with Update or Update action.


Did you check with your Endevor Administrator for more information about Endevor component/Dataset validation
Back to top
View user's profile Send private message
Nic Clouston

Global Moderator


Joined: 10 May 2007
Posts: 1894
Location: UK

PostPosted: Mon Sep 15, 2014 2:53 am    Post subject: Reply to: endevor error
Reply with quote

Quote:
I have retrieved from Prod

How did you retrieve it - by simply copying it in ISPF or using the Endevor Retrieve option?
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> CA Products All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts IEW2456E error when link-editing a C ... Senthilraj JCL & VSAM 0 Fri Oct 13, 2017 3:12 pm
No new posts FTP Skip or ignore error and process ... AJAYREDDY All Other Mainframe Topics 3 Wed Sep 27, 2017 8:12 pm
No new posts Assembler Macro Copybook converted to... Ziquilix PL/I & Assembler 4 Tue Sep 26, 2017 3:07 am
No new posts FUSE - IBM MQ - CICS integration error Kevin Vaz CICS 1 Mon Sep 18, 2017 4:31 pm
No new posts Reply MQ open error Vignesh Sid COBOL Programming 6 Thu Sep 07, 2017 6:02 pm

Facebook
Back to Top
 
Job Vacancies | Forum Rules | Bookmarks | Subscriptions | FAQ | Polls | Contact Us