Portal | Manuals | References | Downloads | Info | Programs | JCLs | Mainframe wiki | Quick Ref
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Profile Log in to check your private messages Log in
 
Facing PROG753 error in few systems only

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> CICS
View previous topic :: :: View next topic  
Author Message
ac288009

New User


Joined: 19 Nov 2013
Posts: 2
Location: switzerland

PostPosted: Wed Nov 20, 2013 3:43 pm    Post subject: Facing PROG753 error in few systems only
Reply with quote

Hi, Online transaction is abending(Struck) with PROG753 error in Z/VSE system.only few users were facing this issue, and for few users it is working fine. so i want to know whether it is the problem with code or it is problem with settings in EXTRA emulator

Thanks,
Ashok
Back to top
View user's profile Send private message

Raghu navaikulam

Active User


Joined: 27 Sep 2008
Posts: 193
Location: chennai

PostPosted: Wed Nov 20, 2013 4:10 pm    Post subject: Reply to: Facing PROG753 error in few systems only
Reply with quote

Hi Ashok,

I am new to VSE. In Z/os, I suspect an initialization problem. If a field is not initialized properly, the result will be unpredictable. Check the fields at the time of ABEND.

Regards
Raghunathan
Back to top
View user's profile Send private message
enrico-sorichetti

Global Moderator


Joined: 14 Mar 2007
Posts: 10326
Location: italy

PostPosted: Wed Nov 20, 2013 4:17 pm    Post subject: Reply to: Facing PROG753 error in few systems only
Reply with quote

not a CICS problem, really, PROGxxx are hardware related errors,
if it happens only on some emulated terminals start looking at differences in the configuration of the emulation.
Back to top
View user's profile Send private message
ac288009

New User


Joined: 19 Nov 2013
Posts: 2
Location: switzerland

PostPosted: Wed Nov 20, 2013 4:52 pm    Post subject: Re: Reply to: Facing PROG753 error in few systems only
Reply with quote

Raghu navaikulam wrote:
Hi Ashok,

I am new to VSE. In Z/os, I suspect an initialization problem. If a field is not initialized properly, the result will be unpredictable. Check the fields at the time of ABEND.

Regards
Raghunathan


Thanks for quick reply.. But the same code is working fine in few systems.. so i hope it is not problem with code...
Back to top
View user's profile Send private message
Robert Sample

Global Moderator


Joined: 06 Jun 2008
Posts: 8165
Location: East Dubuque, Illinois, USA

PostPosted: Wed Nov 20, 2013 5:35 pm    Post subject:
Reply with quote

My Goolge search of PROG753 indicates that LE initialization differences between the systems could cause your problem.
Back to top
View user's profile Send private message
Pepero2k3

New User


Joined: 07 Sep 2008
Posts: 7
Location: Iran

PostPosted: Wed Nov 20, 2013 10:08 pm    Post subject:
Reply with quote

In Z/OS The problem is sending the non printable characters in BMS. There is an 'Storage clear' attribute in the definition of the transaction. When turning on this switch the allocated storage is cleared at first.
Back to top
View user's profile Send private message
Peter cobolskolan

Active User


Joined: 06 Feb 2012
Posts: 104
Location: Sweden

PostPosted: Thu Nov 21, 2013 7:40 pm    Post subject:
Reply with quote

This is probably a programming error. Ensure the Working-Storage used for the output-map is Low-Value before its populated with some data and sent via EXEC CICS SEND MAP('TheMap'), like Move Low-Value to TheMapO.
The problem can occur randomly, as the content of the unitialized Working-Storage/Maparea varies from time to time.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> CICS All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts IEW2456E error when link-editing a C ... Senthilraj JCL & VSAM 0 Fri Oct 13, 2017 3:12 pm
No new posts FTP Skip or ignore error and process ... AJAYREDDY All Other Mainframe Topics 3 Wed Sep 27, 2017 8:12 pm
No new posts Assembler Macro Copybook converted to... Ziquilix PL/I & Assembler 4 Tue Sep 26, 2017 3:07 am
No new posts FUSE - IBM MQ - CICS integration error Kevin Vaz CICS 1 Mon Sep 18, 2017 4:31 pm
No new posts Reply MQ open error Vignesh Sid COBOL Programming 6 Thu Sep 07, 2017 6:02 pm

Facebook
Back to Top
 
Job Vacancies | Forum Rules | Bookmarks | Subscriptions | FAQ | Polls | Contact Us