Portal | Manuals | References | Downloads | Info | Programs | JCLs | Mainframe wiki | Quick Ref
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Profile Log in to check your private messages Log in
 
how to send the zip file

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> All Other Mainframe Topics
View previous topic :: :: View next topic  
Author Message
Sridhar R

New User


Joined: 11 Dec 2010
Posts: 20
Location: India

PostPosted: Tue Dec 21, 2010 12:36 pm    Post subject: how to send the zip file
Reply with quote

how to send the zip file?
Back to top
View user's profile Send private message

Sridhar R

New User


Joined: 11 Dec 2010
Posts: 20
Location: India

PostPosted: Tue Dec 21, 2010 12:37 pm    Post subject:
Reply with quote

if i the file like:

SUBJECT 'AIS EMPLOYEE EXTRACT' +
Msgt 'AIS Employee Extract' +
FROM hrexpress.commonsystems@aholdusa.com +
File ('XT2.SMS.X0HR4.JFESE.AIS.ASSOC.ZP') +
format zip
FILENAME ('AIS_ASSOC_EXT')

i'm getting a error of :

File: 'XT2.SMS.X0HR4.JFESE.AIS.ASSOC.ZP'
Attachment filename: XT2.SMS.X0HR4.JFESE.AIS.ASSOC.ZP.zip
Using ZIP: PKZIP
zip file as: XT2.SMS.X0HR4.JFESE.AIS.ASSOC.ZP.txt
zip'ing file 'XT2.SMS.X0HR4.JFESE.AIS.ASSOC.ZP'
with name-in-archive of XT2.SMS.X0HR4.JFESE.AIS.ASSOC.ZP.txt
++ x_rc = encode64( "in.", "encode." )
++ call do_base64
++ call process_file
Error running XMITIP, line 5159: Routine not found
Back to top
View user's profile Send private message
enrico-sorichetti

Global Moderator


Joined: 14 Mar 2007
Posts: 10308
Location: italy

PostPosted: Tue Dec 21, 2010 1:36 pm    Post subject: Reply to: how to send the zip file using jcl?
Reply with quote

since You are having an XMITIP issue and XMITIP Is well documented
why not look at the docs
google for XMITIP and You will find them easily
Back to top
View user's profile Send private message
Sridhar R

New User


Joined: 11 Dec 2010
Posts: 20
Location: India

PostPosted: Tue Dec 21, 2010 2:00 pm    Post subject:
Reply with quote

oh....thankyou so much i'll check the docment and i'll get you get you back

regards,
sridhar
Back to top
View user's profile Send private message
dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Tue Dec 21, 2010 9:37 pm    Post subject:
Reply with quote

Hello,

In addition to reading the documentation, i suggest you find another XMIT process that is working correctly on your system and compare this to the one that is having problems .
Back to top
View user's profile Send private message
Sridhar R

New User


Joined: 11 Dec 2010
Posts: 20
Location: India

PostPosted: Thu Dec 23, 2010 6:42 am    Post subject:
Reply with quote

i have followed as per the document even though i'm facing the same error...

please give solution for this issue.
Back to top
View user's profile Send private message
dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Thu Dec 23, 2010 10:23 am    Post subject:
Reply with quote

Hello,

So, there is No Other process doing this on your entire system. . .?

What is line 5159? What routine is not found? Only you can tell this as it is specific to whatever you are running.

You need to talk with whoever installed/supports XMITIP on your system. There is the possibility that your installation of XMITIP needs adjustment (more current version or something related to some other upgrade on the system).
Back to top
View user's profile Send private message
Sridhar R

New User


Joined: 11 Dec 2010
Posts: 20
Location: India

PostPosted: Thu Dec 23, 2010 10:38 am    Post subject:
Reply with quote

ok i'll check with my team regarding this...

Thanks!!!


Can you please tell me what is this sentence means?

++ x_rc = encode64( "in.", "encode." )
++ call do_base64
++ call process_file
Back to top
View user's profile Send private message
enrico-sorichetti

Global Moderator


Joined: 14 Mar 2007
Posts: 10308
Location: italy

PostPosted: Thu Dec 23, 2010 11:19 am    Post subject: Reply to: how to send the zip file
Reply with quote

the call sequence is reversed ( last to first )
encode64 was not found

encode64 is a load module

review the installation to have encode 64 available
as per installation documentation
or as per reading XMITIP source itself
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> All Other Mainframe Topics All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Compare yesterday's date to the one o... migusd SYNCSORT 8 Fri Sep 22, 2017 11:35 pm
No new posts Split 1 file into 10 output Files - S... Prasanth Kumar SYNCSORT 5 Sat Sep 16, 2017 12:02 am
No new posts BUILD OUTFIL based on condition other... balaji81_k DFSORT/ICETOOL 13 Fri Sep 08, 2017 11:06 pm
No new posts Skip file from delete pema_yozer All Other Mainframe Topics 3 Tue Aug 29, 2017 3:19 pm
No new posts editting the file by inserting zeros ... pramodrsingh DFSORT/ICETOOL 9 Mon Aug 21, 2017 5:58 pm

Facebook
Back to Top
 
Job Vacancies | Forum Rules | Bookmarks | Subscriptions | FAQ | Polls | Contact Us