Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

Running Jobs between different mainframes
Goto page 1, 2  Next
 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> All Other Mainframe Topics
View previous topic :: :: View next topic  
Author Message
karisurya

New User


Joined: 02 Aug 2007
Posts: 64
Location: Bangalore

PostPosted: Tue Feb 03, 2009 7:36 pm    Post subject: Running Jobs between different mainframes
Reply with quote

Hi,
We have 2 mainframe's Say X and Y and as a part of batch cycle execution We execute some jobs in "Y" XMIT (transfer) some data in the form of seq file from "Y" to "X". Later go and submit some jobs in "X" which uses this file.
Now the problem i am facing in automating this process is i dont know how to execute jobs in mainframe "X" from Mainframe "Y" and get back status.

Basically i am trying to find a way where i can trigger a process thru rexx which subit jobs in some other mainframe and get back job status.

Please let me know if any of you faced this issue or any other ideas to solve this problem.
Back to top
View user's profile Send private message

superk

Moderator Team Head


Joined: 26 Apr 2004
Posts: 4648
Location: Raleigh, NC, USA

PostPosted: Tue Feb 03, 2009 7:43 pm    Post subject: Reply to: Running Jobs between different mainframes
Reply with quote

FTP?
/*ROUTE XEQ?
NJE or RJE?
Connect:Direct (NDM)?
Back to top
View user's profile Send private message
karisurya

New User


Joined: 02 Aug 2007
Posts: 64
Location: Bangalore

PostPosted: Tue Feb 03, 2009 8:25 pm    Post subject:
Reply with quote

I am sorry superk i did not get your point, i guess u r asking me what we are using to transfer data between mainframe, in general to manually transfer data i use XMIT userid.dsn('xxx').

Can you explain how to use ftp or some thing else to trigger jobs in some other mainframe?

Please let me know if u need further info.
Back to top
View user's profile Send private message
Robert Sample

Global Moderator


Joined: 06 Jun 2008
Posts: 7913
Location: Bellevue, IA

PostPosted: Tue Feb 03, 2009 8:39 pm    Post subject:
Reply with quote

Quote:
Can you explain how to use ftp or some thing else to trigger jobs in some other mainframe?
You don't trigger jobs on the other mainframe using FTP -- you submit them. Use SITE FILETYPE=JES and you can FTP directly into the JES spool so the job runs on the other mainframe.

Kevin was giving you some of the ways a job can be submitted from one machine to another -- which you use depends largely on the details of what you want to do.
Back to top
View user's profile Send private message
karisurya

New User


Joined: 02 Aug 2007
Posts: 64
Location: Bangalore

PostPosted: Tue Feb 03, 2009 8:44 pm    Post subject:
Reply with quote

Hi Robert,

Thanks for correcting me, can you help me with a sample jcl to do this task or direct me where i can get this info in detail.

Thanks& Regards,
Surya
Back to top
View user's profile Send private message
Robert Sample

Global Moderator


Joined: 06 Jun 2008
Posts: 7913
Location: Bellevue, IA

PostPosted: Tue Feb 03, 2009 8:46 pm    Post subject:
Reply with quote

Find the IBM Communications Server User's Guide for your release of z/OS and review the FTP information. Check out the SITE FILETYPE=JES command in particular. If you don't have local access to this manual you can find it at the IBM web site, as usual.
Back to top
View user's profile Send private message
expat

Global Moderator


Joined: 14 Mar 2007
Posts: 8593
Location: Back in jolly old England

PostPosted: Tue Feb 03, 2009 8:49 pm    Post subject:
Reply with quote

I usually use the /*ROUTE XEQ method
Back to top
View user's profile Send private message
karisurya

New User


Joined: 02 Aug 2007
Posts: 64
Location: Bangalore

PostPosted: Wed Feb 04, 2009 3:33 pm    Post subject:
Reply with quote

As suggested by expat i tried using /*ROUTE XEQ XXXX(NODE) AFTER JOB CARD but i am getting a error stating
"REMOTE JOB CARD NOT FOUND"

can any one help me with this as i am not sure why i am getting this error?
Back to top
View user's profile Send private message
Anuj Dhawan

Senior Member


Joined: 22 Apr 2006
Posts: 6258
Location: Mumbai, India

PostPosted: Wed Feb 04, 2009 5:54 pm    Post subject:
Reply with quote

Hi,

May be showing the "actual" code would fetch better replies..
Back to top
View user's profile Send private message
expat

Global Moderator


Joined: 14 Mar 2007
Posts: 8593
Location: Back in jolly old England

PostPosted: Wed Feb 04, 2009 5:55 pm    Post subject:
Reply with quote

And the actual error code shown in the messages
Back to top
View user's profile Send private message
Robert Sample

Global Moderator


Joined: 06 Jun 2008
Posts: 7913
Location: Bellevue, IA

PostPosted: Wed Feb 04, 2009 6:18 pm    Post subject:
Reply with quote

Let's start with some basics -- are you using JES2 or JES3? What's the node names for the machines you're calling X and Y in your original post?
Back to top
View user's profile Send private message
karisurya

New User


Joined: 02 Aug 2007
Posts: 64
Location: Bangalore

PostPosted: Wed Feb 04, 2009 6:37 pm    Post subject:
Reply with quote

I am using JES3
Nodes are: TORGPC AND SYGMA1

Initially i got the following error message
IAT6176 REMOTE JOB CARD NOT FOUND
//DELTETMP EXEC PGM=IEFBR14
IRR010I USERID XXXXXXX IS ASSIGNED TO THIS JOB.

Later after reading the manul i include a new job card and used NJB instead of JOB for 2nd job card and after execution i started getting a new error as follows:
BSSM080 XXXXXXX IS THE SUBMITTER USERID
ICH408I USER(XXXXXXX ) GROUP(ABCDEFG ) NAME(SUPPORT TEAM )
LOGON/JOB INITIATION - INVALID GROUP

I am assuming I might not have enough authorization to execute this task, please let me know is my understanding is correct?

Let me know in case if you guys need any more info.
Back to top
View user's profile Send private message
karisurya

New User


Joined: 02 Aug 2007
Posts: 64
Location: Bangalore

PostPosted: Wed Feb 04, 2009 6:41 pm    Post subject:
Reply with quote

If you are looking for actual code here it is:

//JJJOB1 JOB (TEST),'SAMPLE JOB',MSGCLASS=7,NOTIFY=&SYSUID
//*ROUTE XEQ TORGPC
//JJJOB2 NJB (TST1),'SAMPLE JOB',MSGCLASS=7,NOTIFY=&SYSUID
//*************************************************
//ALLOCTM2 EXEC PGM=IEFBR14
//SYSPRINT DD SYSOUT=*
//SYSUT1 DD DSN=TSPQR.SURYA.OUTPUT.TEST,
// DISP=(NEW,CATLG,DELETE),
// DCB=(RECFM=FB,LRECL=80,BLKSIZE=0),
// UNIT=TSO,SPACE=(TRK,(1,1),RLSE)
Back to top
View user's profile Send private message
Robert Sample

Global Moderator


Joined: 06 Jun 2008
Posts: 7913
Location: Bellevue, IA

PostPosted: Wed Feb 04, 2009 6:43 pm    Post subject:
Reply with quote

From the manual, I believe this (untested) code should work:
Code:
//JOBNAME1  JOB ...
//*ROUTE XEQ SYGMA1
//JOBNAME2 JOB ...
.
.
.
//
But I can't really test this at our site so I can't say for sure if the JCL is good.
Back to top
View user's profile Send private message
Anuj Dhawan

Senior Member


Joined: 22 Apr 2006
Posts: 6258
Location: Mumbai, India

PostPosted: Wed Feb 04, 2009 6:56 pm    Post subject:
Reply with quote

Hi,

Should not this
Code:
 //*ROUTE
has a single "/", such as
Code:
/*ROUTE
.
Back to top
View user's profile Send private message
Gnanas N

Active Member


Joined: 06 Sep 2007
Posts: 785
Location: Chennai, India

PostPosted: Wed Feb 04, 2009 6:58 pm    Post subject:
Reply with quote

It seems your JCL is correct.
Quote:
ICH408I USER(XXXXXXX ) GROUP(ABCDEFG ) NAME(SUPPORT TEAM )
LOGON/JOB INITIATION - INVALID GROUP

Code:
ICH408I LOGON/JOB INITIATION - INVALID GROUP           
                                                       
You attempted to log on to TSO or submit a batch job   
using a group ID that is not defined to RACF. If the   
group ID was misskeyed, correct it and retry the       
request, otherwise contact the Security Administrator 
to obtain an appropriate group ID.               
Back to top
View user's profile Send private message
Robert Sample

Global Moderator


Joined: 06 Jun 2008
Posts: 7913
Location: Bellevue, IA

PostPosted: Wed Feb 04, 2009 7:02 pm    Post subject:
Reply with quote

Anuj -- JES2 uses /*ROUTE while JES3 uses //*ROUTE.
Back to top
View user's profile Send private message
karisurya

New User


Joined: 02 Aug 2007
Posts: 64
Location: Bangalore

PostPosted: Wed Feb 04, 2009 7:13 pm    Post subject:
Reply with quote

I think //*ROUTE is correct for JES3 after doing some research on the error i am getting, Here is the explanation i found in IBM manual

"INVALID GROUP The user tried to log on or to initiate a job using a group that the user is not a member of. "

Based on this i went back and seen the RACF permission i am having
I belong to A9ZGDEV in SYGMA1
and A9ZDEVG in TORGPC

So i guess when i am trying to submit the job from SYGMA1 it is using that group id when submitting job in TORGPC. Please let me know is my understanding correct? if so is there any other way to over come this problem?
Back to top
View user's profile Send private message
Robert Sample

Global Moderator


Joined: 06 Jun 2008
Posts: 7913
Location: Bellevue, IA

PostPosted: Wed Feb 04, 2009 7:19 pm    Post subject:
Reply with quote

I believe your understanding is correct. Try using GROUP=A9ZDEVG on your second job card (your may need the user id and password as well but try just the group first).
Back to top
View user's profile Send private message
karisurya

New User


Joined: 02 Aug 2007
Posts: 64
Location: Bangalore

PostPosted: Wed Feb 04, 2009 7:38 pm    Post subject:
Reply with quote

Robert after adding GROUP in job card it is working fine now as expected.

I have one more question related to this how to capture the status of the job executed in different region. The idea is once the job completes successfully in other region, i need to capture that info and execute some other jobs in the present region.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> All Other Mainframe Topics All times are GMT + 6 Hours
Goto page 1, 2  Next
Page 1 of 2

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Problem in Running Query via JCL vickey_dw DB2 3 Tue Oct 18, 2016 11:11 pm
No new posts How to show message using batch jobs madprasy TSO/ISPF 7 Fri Sep 09, 2016 6:55 pm
No new posts Don't allow CICS to submit batch jobs prino JCL & VSAM 5 Mon Jul 25, 2016 3:26 pm
No new posts Predicting jobs which are about to re... kpanchabhai85 DFSORT/ICETOOL 4 Thu Jun 30, 2016 7:51 pm
No new posts creating a physical sequential file i... Shaheen Shaik JCL & VSAM 8 Wed Jun 29, 2016 3:46 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us