Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

Problem in Xpeditor with Changeman

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> Compuware & Other Tools
View previous topic :: :: View next topic  
Author Message
parikshit123

Active User


Joined: 01 Jul 2005
Posts: 269
Location: India

PostPosted: Thu May 31, 2007 10:14 am    Post subject: Problem in Xpeditor with Changeman
Reply with quote

Hi Gurus,

I am facing problem in xpeditor set up. When I try to xpedite a program, it says "Source Listing is not found ....".

We have Changeman at our shop. Can anyone please help me resolve this?

I believe, there is some problem with the DDIO file. I have tried to create my personal DDIO file as well. But still the problem is there.
Back to top
View user's profile Send private message

Devzee

Active Member


Joined: 20 Jan 2007
Posts: 684
Location: Hollywood

PostPosted: Thu May 31, 2007 11:41 am    Post subject:
Reply with quote

Have you set XPED option while compiling within CHANGEMAN?
Back to top
View user's profile Send private message
muthuvel

Active User


Joined: 29 Nov 2005
Posts: 217
Location: Chennai

PostPosted: Thu May 31, 2007 12:10 pm    Post subject: Re: Problem in Xpeditor with Changeman
Reply with quote

I am not much aware of xpeditor but in the tracing tool which our firm uses if it says "source listing not found",we recompile and add the program to test region again.
Back to top
View user's profile Send private message
Devzee

Active Member


Joined: 20 Jan 2007
Posts: 684
Location: Hollywood

PostPosted: Thu May 31, 2007 12:14 pm    Post subject:
Reply with quote

Quote:
we recompile and add the program to test region again.

I agree this is what we do if the program is compiled using compile JCL, but if the cobol program is in CHGMAN and to use the CHGMAN compiled version in Xpeditor then you got to compile with XPED option within CHGMAN.
Back to top
View user's profile Send private message
parikshit123

Active User


Joined: 01 Jul 2005
Posts: 269
Location: India

PostPosted: Thu May 31, 2007 1:54 pm    Post subject:
Reply with quote

I have already staged the program with XPED = Y option in changeman.

Can anyone tell me which DDIO file should I use? Do I need to create my own DDIO file or changeman does it for me.
Back to top
View user's profile Send private message
Devzee

Active Member


Joined: 20 Jan 2007
Posts: 684
Location: Hollywood

PostPosted: Thu May 31, 2007 1:56 pm    Post subject:
Reply with quote

Since you are using loadmodule compiled with CHGMAN and XPED opotion, You got to use the DDIO file of Changeman
Back to top
View user's profile Send private message
ofer71

Global Moderator


Joined: 27 Dec 2005
Posts: 2360
Location: Israel

PostPosted: Thu May 31, 2007 2:59 pm    Post subject:
Reply with quote

One thing to keep in mind when working with ChangeMan: The source is usually saved with PACKED mode ON. That's why tools and utilities often find it difficult to read the source.

O.
Back to top
View user's profile Send private message
parikshit123

Active User


Joined: 01 Jul 2005
Posts: 269
Location: India

PostPosted: Thu May 31, 2007 5:06 pm    Post subject:
Reply with quote

so, how can I find the DDIO file of changeman?
Back to top
View user's profile Send private message
Devzee

Active Member


Joined: 20 Jan 2007
Posts: 684
Location: Hollywood

PostPosted: Thu May 31, 2007 6:47 pm    Post subject:
Reply with quote

Look at your compile job and find for DDIO and then use that DDIO file name,
Back to top
View user's profile Send private message
parikshit123

Active User


Joined: 01 Jul 2005
Posts: 269
Location: India

PostPosted: Fri Jun 01, 2007 1:08 pm    Post subject: Re: Problem in Xpeditor with Changeman
Reply with quote

Hi,

I have done that. But somewhere soemthing is wrong from my side.

Please have a look at the attached changeman compile JCL & opine as to which loadlib and which DDIO file that I should use.

I have used TPE.CYA01.#002137.LOD as a loadlib and TPE.ACHGMAND.DDIO as a ddio file.

I can see that the loadlib is uptodate with the new load member when I execute the CM compile jcl
& I can see that the ddio file also has the correct program.
Back to top
View user's profile Send private message
Devzee

Active Member


Joined: 20 Jan 2007
Posts: 684
Location: Hollywood

PostPosted: Fri Jun 01, 2007 7:19 pm    Post subject:
Reply with quote

The load lib and ddio mentioned by you looks to be correct. I dont see issues with that.

Is your compilation succesful. Did the Compile job created listing in DDIO file? check the return code ?

How is your Xped setup? Load lib and DDIO file?
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> Compuware & Other Tools All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Problem reading GTF trace output danik56 ABENDS & Debugging 7 Thu Mar 16, 2017 1:02 pm
No new posts ROUNDED Problem with COMPUTE statement shalem COBOL Programming 11 Thu Feb 09, 2017 8:16 pm
No new posts SYMNAMES problem jacobdng DFSORT/ICETOOL 7 Thu Dec 22, 2016 7:47 am
No new posts Problem in writing Output file vickey_dw COBOL Programming 5 Mon Nov 14, 2016 11:14 pm
No new posts Problem in Running Query via JCL vickey_dw DB2 3 Tue Oct 18, 2016 11:11 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us