Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

Getting "I/O error reading data" during opening me

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> TSO/ISPF
View previous topic :: :: View next topic  
Author Message
asvijay

New User


Joined: 13 Jul 2006
Posts: 11

PostPosted: Mon Jul 24, 2006 3:28 pm    Post subject: Getting "I/O error reading data" during opening me
Reply with quote

Hi,
Could you please explain me what this error is? when i'm trying to open the member in VIEW mode its giving error as "I/O error reading data"

Regards,
Vijay
Back to top
View user's profile Send private message

mainframemouli

New User


Joined: 01 Mar 2005
Posts: 52
Location: Mysore

PostPosted: Tue Jul 25, 2006 11:33 am    Post subject: Re: Getting "I/O error reading data" during openin
Reply with quote

The member that you are trying to open , might be opened by some one else before you open that . And there was a session logged out or connection failure when He/She read that member.
Back to top
View user's profile Send private message
asvijay

New User


Joined: 13 Jul 2006
Posts: 11

PostPosted: Tue Jul 25, 2006 11:40 am    Post subject:
Reply with quote

mfmouli,
Yes even we tried to figure out whether that dataset is opened by someone or not. But no one did that because that is the personal dataset. And we are facing this issue for the past one month, meaning for past one month we are trying to open the dataset but getting the same error.
does it make sense?pls help me out.
Back to top
View user's profile Send private message
mainframemouli

New User


Joined: 01 Mar 2005
Posts: 52
Location: Mysore

PostPosted: Tue Jul 25, 2006 12:18 pm    Post subject:
Reply with quote

when u try to open with EDIT mode and browse mode , its opening properly rite...its the problem only with view mode!!!!!!
Back to top
View user's profile Send private message
theladyd

New User


Joined: 18 Oct 2006
Posts: 1

PostPosted: Tue Oct 24, 2006 2:24 am    Post subject: Re: Getting "I/O error reading data" during openin
Reply with quote

I'm having a similar problem. I list and browse my dataset, but I cannot open/edit a member. It always give me "I/O error reading data". Also, it allows me to add a member and to edit the new member, but the the preexisting members.

How do I fix the problem? I've been trying to clear this error for two weeks.

Thanks in advance for any help available. icon_redface.gif
Back to top
View user's profile Send private message
Bill Dennis

Active Member


Joined: 17 Aug 2007
Posts: 562
Location: Iowa, USA

PostPosted: Tue Nov 11, 2008 10:06 pm    Post subject:
Reply with quote

If you can add new members but not read old members then the DCB info (LRECL,BLKSIZE) was probably altered by some batch job with the PDS as output.

You need to rerun the batch job pointing to the PDS(member) and give the correct LRECL,BLKSIZE. Delete the newest members as they may now be unreadable.
Back to top
View user's profile Send private message
enrico-sorichetti

Global Moderator


Joined: 14 Mar 2007
Posts: 10231
Location: italy

PostPosted: Tue Nov 11, 2008 10:18 pm    Post subject: Reply to: Getting "I/O error reading data" during
Reply with quote

search the forum for "corrupted pds"
check the button for search all the terms
and You will find a few posts telling how to proceed
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> TSO/ISPF All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Export flat file data into excel sheet murali.andaluri DFSORT/ICETOOL 2 Mon Mar 20, 2017 5:39 pm
No new posts Need help with below DB2 error ashek15 DB2 3 Sat Mar 18, 2017 5:56 am
No new posts Append data from two files into a sin... Praveen04 DFSORT/ICETOOL 5 Thu Mar 16, 2017 7:29 pm
No new posts Problem reading GTF trace output danik56 ABENDS & Debugging 7 Thu Mar 16, 2017 1:02 pm
No new posts FINDREP Syntax Error seahawk789 DFSORT/ICETOOL 4 Thu Mar 09, 2017 10:11 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us