Portal | Manuals | References | Downloads | Info | Programs | JCLs | Mainframe wiki | Quick Ref
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Profile Log in to check your private messages Log in
 
SDSF - SJ command not working properly

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> IBM Tools
View previous topic :: :: View next topic  
Author Message
mistah kurtz

Active User


Joined: 28 Jan 2012
Posts: 310
Location: Room: TREE(3). Hilbert's Hotel

PostPosted: Tue Jun 26, 2018 2:33 pm    Post subject: SDSF - SJ command not working properly
Reply with quote

Hi ,

Earlier SJ command was working as expected,i.e., if you type SJ against a job in spool it will display the job in edit mode. But suddenly it is behaving differently. Now I am getting an empty display as below:

Code:
SDSF EDIT XXXXXXXL (JOB12945) JCLEDIT Columns 00001 00072
Command ===>                                                   Scroll ===> CSR
****** ***************************** Top of Data ******************************
''''''
''''''
''''''
''''''
''''''
''''''
''''''
''''''


Further If I press PF3 on this screen i get below message:
Code:
SDSF EDIT AFD10D9L (JOB12945) JCLEDIT                      Deactivated command
Command ===>                                                   Scroll ===> CSR
****** ***************************** Top of Data ******************************
****** **************************** Bottom of Data ****************************


Could you please suggest what could I have done wrong?
Back to top
View user's profile Send private message

vasanthz

Global Moderator


Joined: 28 Aug 2007
Posts: 1623
Location: Oregon

PostPosted: Tue Jun 26, 2018 11:00 pm    Post subject:
Reply with quote

When you receive the message "Deactivated command".
Can you press the PF1 or help key and post what you see.

Weird and interesting
Back to top
View user's profile Send private message
Rohit Umarjikar

Senior Member


Joined: 21 Sep 2010
Posts: 2114
Location: NY,USA

PostPosted: Wed Jun 27, 2018 1:19 am    Post subject:
Reply with quote

Shouldn't this site specific? At my site it works so something is wrong with macros at your site. Did you follow up with anyone out there?
Back to top
View user's profile Send private message
mistah kurtz

Active User


Joined: 28 Jan 2012
Posts: 310
Location: Room: TREE(3). Hilbert's Hotel

PostPosted: Wed Jun 27, 2018 3:04 pm    Post subject:
Reply with quote

The message that i got is: "END COMMAND HAS BEEN DEACTIVATED"

Meanwhile I have noticed that the profile is locked in SDSF:
Code:
ISFEDIT (VARIABLE - 81)....RECOVERY OFF WARN....NUMBER OFF.
CAPS ON....HEX OFF....NULLS ON STD....TABS OFF.............
AUTOSAVE ON....AUTONUM OFF....AUTOLIST OFF....STATS OFF....
PROFILE LOCK....IMACRO DELE....PACK OFF....NOTE ON.........
HILITE JCL CURSOR FIND.....................................


But it's unlocked in if check in ISPF. I have raised a ticket with the site support team. Waiting for their response.
Back to top
View user's profile Send private message
mistah kurtz

Active User


Joined: 28 Jan 2012
Posts: 310
Location: Room: TREE(3). Hilbert's Hotel

PostPosted: Wed Jun 27, 2018 5:18 pm    Post subject:
Reply with quote

Update: I was able to unlock the profile and reset the initial macro which was incorrectly set to DELE. Now it's working as expected.

Thanks icon_smile.gif
Back to top
View user's profile Send private message
Rohit Umarjikar

Senior Member


Joined: 21 Sep 2010
Posts: 2114
Location: NY,USA

PostPosted: Wed Jun 27, 2018 10:00 pm    Post subject:
Reply with quote

Thanks for posting the resolution back , it will help to others in the same situations.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> IBM Tools All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts SDSF limit access to specifc output c... David Beckham All Other Mainframe Topics 0 Thu Mar 21, 2019 10:29 pm
No new posts SDSF JOES Deon Campbell CLIST & REXX 2 Thu Mar 21, 2019 2:50 am
No new posts how to copy a sequential dataset by u... javen777 JCL & VSAM 3 Thu Feb 21, 2019 11:37 pm
No new posts DSLIST Command is not working thesumitk TSO/ISPF 14 Mon Dec 10, 2018 8:10 pm
No new posts Using SPUFI with DISTINCT and MAX is ... Time2Live DB2 8 Fri Nov 30, 2018 6:24 am

Facebook
Back to Top
 
Job Vacancies | Forum Rules | Bookmarks | Subscriptions | FAQ | Polls | Contact Us