Portal | Manuals | References | Downloads | Info | Programs | JCLs | Mainframe wiki | Quick Ref
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Profile Log in to check your private messages Log in
 
VSAM AIX is not populating base cluster data

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> JCL & VSAM
View previous topic :: :: View next topic  
Author Message
Satheeshkumar

New User


Joined: 20 Feb 2009
Posts: 51
Location: Chennai

PostPosted: Sun Oct 20, 2013 9:32 am    Post subject: VSAM AIX is not populating base cluster data
Reply with quote

Dear Sir,

The issue is we have alternate index even though base cluster is populated(insert,delete or update), the AIX do not show any value for the populated in base.
TEST.MASTER.FILE.AIX1

The AIX is defined with upgrade parameter and but not sure why data is not populating from base cluster.
when i rebuild AIX the data is populating from base cluster, but i want the AIX to populate the data automatically whenever base cluster data( updated or inserted or deleted)

Please provide your inputs help in identifying the reason for this issue
Back to top
View user's profile Send private message

Bill Woodger

DFSORT Moderator


Joined: 09 Mar 2011
Posts: 7314

PostPosted: Sun Oct 20, 2013 12:54 pm    Post subject: Reply to: VSAM AIX is not populating base cluster data
Reply with quote

How about a LISTCAT enclosed in the Code tags?

Where is the file bieng used? What language(s) or whatever are doing the work?
Back to top
View user's profile Send private message
Robert Sample

Global Moderator


Joined: 06 Jun 2008
Posts: 8449
Location: Dubuque, Iowa, USA

PostPosted: Sun Oct 20, 2013 5:55 pm    Post subject:
Reply with quote

Are you updating in batch or online?
If batch, show the JCL yhou are using (again with CODE tags).
As Bill said, show the LISTCAT (with CODE tags).
How are you determining that the alternate index is not being updated?
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> JCL & VSAM All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Regarding mroe data to be processed i... vinu78 DB2 1 Mon May 27, 2019 7:31 pm
No new posts masking data with HPU jzhardy DB2 0 Tue May 14, 2019 2:43 pm
No new posts How to browse RECFM=VBS DSORG=PSE seq... Alan Playford JCL & VSAM 7 Fri May 10, 2019 2:59 pm
No new posts data conversion error maxsubrat PL/I & Assembler 4 Thu May 09, 2019 10:57 pm
No new posts How to Hash a data inCOBOL Log Thangavel COBOL Programming 10 Tue May 07, 2019 8:35 pm

Facebook
Back to Top
 
Job Vacancies | Forum Rules | Bookmarks | Subscriptions | FAQ | Polls | Contact Us