Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

JOB not in spool

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> JCL & VSAM
View previous topic :: :: View next topic  
Author Message
ashokkumarsahu

New User


Joined: 03 Aug 2005
Posts: 6
Location: bangalore

PostPosted: Tue Oct 04, 2005 6:07 pm    Post subject: JOB not in spool
Reply with quote

Hi
I am not able to see my job in spool.After submitting the job it's fine it is

showing job submitted.But in spool it's not coming .I have tried with

PRE OWNER command etc but still not working.I came to know that i have

to do some setting in FILTER of SDSF panel .Can any one pls give the

details how to do the filter setting .

Thanks in advance
Back to top
View user's profile Send private message

hyuzen

New User


Joined: 10 Jul 2005
Posts: 58

PostPosted: Wed Oct 05, 2005 1:53 am    Post subject: Re: JOB not in spool
Reply with quote

Hi,

Use these commands from SDSF command input:
Pre;owner;dest

Submitting job does not necessarily mean it will work. Check input queue, it may be there if u coded typrun=hold at its job card. Better post first lines of your job or at least job card.

All corrections welcome

Hyuzen
Back to top
View user's profile Send private message
mvanandkumar

New User


Joined: 01 Sep 2005
Posts: 11

PostPosted: Wed Oct 05, 2005 7:07 am    Post subject:
Reply with quote

Hi,

Ashok - I presume there is no HOLD parm in your JOB Card. icon_redface.gif

hyuzen - To simulate just remove a quote from Job Statements Dept or Programmers (free from text) field and submit the job. icon_wink.gif

To all,

The system does allocate jobnum and DOES tries to execute the JCL. however the job listing will be DELETED (I guess this is site installation dependent). To check go to SYSLOG (provided you have access to it) and search for your jobname, there you will find the message - JCL Error and job purged messages. icon_eek.gif

Thanks
Anand
Back to top
View user's profile Send private message
Gautam512

Active User


Joined: 05 Oct 2005
Posts: 309
Location: Vizag / US

PostPosted: Wed Oct 05, 2005 9:50 pm    Post subject: check this
Reply with quote

Hi,

just give NOTIFY=&SYSUID in ur job card..that might solve ur problem...

Thanks
Gau
Back to top
View user's profile Send private message
priyesh.agrawal

Senior Member


Joined: 28 Mar 2005
Posts: 1452
Location: Chicago, IL

PostPosted: Wed Oct 05, 2005 10:19 pm    Post subject: Re: JOB not in spool
Reply with quote

Quote:
just give NOTIFY=&SYSUID in ur job card..that might solve ur problem...


Gau... AFAIK, NOTIFY has not to do anything with that (Job in spool)..... That is useful only to display jobs status once it is completed successfully or not.

Ashok....

What I think....You should verify MSGCLASS PARAMETER in your jobcard..... Hopefully, That should end your search.

Regards,

Priyesh.
Back to top
View user's profile Send private message
sourab
Warnings : 1

New User


Joined: 05 Oct 2005
Posts: 6

PostPosted: Thu Oct 06, 2005 1:57 am    Post subject:
Reply with quote

Possibilities are :
1. CHECK FOR MSGCLASS. MAKE SURE JOB IS NOT DIRECTED TO $AVERS.
2. Check for the Jobname (From Jobcard of JCL) and in spool type
PRE <JOBNAME>.
OWNER *
or you can specify
OWNER <YOUR ID>. If you have used any other id/passwd (in the job) then specify that id.

3. Sometimes its because of of the job Class. Make sure that system holds the job for long enough time in spool for the given job class.

Hope that will help
Back to top
View user's profile Send private message
Anbudan

New User


Joined: 07 Sep 2005
Posts: 26
Location: Germany

PostPosted: Thu Oct 06, 2005 6:56 pm    Post subject:
Reply with quote

Hi ashokkumarsahu


I agree with priyesh.agrawal

The problem is with MSGCLASS

Solution:

In general, MSGCLASS=T shows the result at ur spool.

To see your previous resut,

use WSF on ispf panel.


Still doubts........, No problem, ask me



Anbudan
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> JCL & VSAM All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
This topic is locked: you cannot edit posts or make replies. SDSF multiple spool datasets extracte... PJAlarcon CLIST & REXX 1 Fri Apr 21, 2017 10:50 pm
No new posts REXX cdoe to purge a JOB from spool a... Sulabh Agrawal CLIST & REXX 11 Thu Mar 09, 2017 11:36 am
No new posts Report output in Spool amitc23 JCL & VSAM 4 Tue Apr 26, 2016 4:32 pm
No new posts Extract specific step spool data enrico-sorichetti JCL & VSAM 1 Thu Feb 04, 2016 9:48 am
No new posts XML generated from cobol is displayin... vangeti COBOL Programming 2 Wed Aug 19, 2015 5:16 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us