Portal | Manuals | References | Downloads | Info | Programs | JCLs | Mainframe wiki | Quick Ref
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Profile Log in to check your private messages Log in
 
CICS MAP data is not displayed

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> CICS
View previous topic :: :: View next topic  
Author Message
baratchandar

New User


Joined: 13 Jun 2009
Posts: 11
Location: chennai

PostPosted: Fri Oct 19, 2012 11:31 pm    Post subject: CICS MAP data is not displayed
Reply with quote

Hi ,

In CICS i try created new screen(tran), which is copy of existing screen but only display option is provided here. So i mirrored the previous screen code,Map everything and executed.But data displayed is corrupted.


Ex screen1->need to select state
screen2 ->need to select option(display update)
screen3->need to select city
screen 4 will display data for update

i create new to screen and added the update option in the screen2 which takes me to screen 3 .After selecting city on screen 3 and then it navigates to screen 5(new screen) exact copy of screen 4.

But data is not displayed corrected. somvalues are not displayed

ex
1) cityname,statename are not displayed
2) shop details in the city are corrupted

I gave fset for dynamic attributes. but still its populating as blank


state-city - ca-las
(label) dynamic

I am getting

state-city - blank

But values are stored in the dyanmic values, I tr to move the dyamic values into the label name its working

ca-las
(replaced state city using ca-las). But its not displaying in actual position.Please help.

Thanks icon_confused.gif
Back to top
View user's profile Send private message

Peter cobolskolan

Active User


Joined: 06 Feb 2012
Posts: 104
Location: Sweden

PostPosted: Sat Oct 20, 2012 12:01 pm    Post subject:
Reply with quote

Why do you think we can solve a programming error without seeing the code?
Back to top
View user's profile Send private message
Nic Clouston

Global Moderator


Joined: 10 May 2007
Posts: 1894
Location: UK

PostPosted: Sat Oct 20, 2012 1:11 pm    Post subject:
Reply with quote

Try assigning the data to the data field on the screen instead of the label field (at least the latter sounds like what you currently do).
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> CICS All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Identifying Interfaces in CICS/mainframe Ashishpanpaliya CICS 5 Fri Oct 13, 2017 3:21 pm
No new posts Copy 4 byte of data from the last rec... arunsoods DFSORT/ICETOOL 9 Fri Oct 06, 2017 12:15 pm
No new posts opening a dataset after reading it fr... arunsoods DFSORT/ICETOOL 5 Wed Oct 04, 2017 3:54 pm
No new posts Accessing CICS tran with map from JCL... navdeepaggarwal CICS 5 Tue Oct 03, 2017 6:15 pm
This topic is locked: you cannot edit posts or make replies. PS file data should be passed as symb... d_sarlie JCL & VSAM 15 Tue Oct 03, 2017 5:18 am

Facebook
Back to Top
 
Job Vacancies | Forum Rules | Bookmarks | Subscriptions | FAQ | Polls | Contact Us