Portal | Manuals | References | Downloads | Info | Programs | JCLs | Mainframe wiki | Quick Ref
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Profile Log in to check your private messages Log in
 
Return code 0000 oppose to 0

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> TSO/ISPF
View previous topic :: :: View next topic  
Author Message
kranthikumarb

Active User


Joined: 02 Jan 2009
Posts: 115
Location: Hyderabad

PostPosted: Tue Aug 14, 2012 8:47 pm    Post subject: Return code 0000 oppose to 0
Reply with quote

Hi All,

I used to get a return code 0 on successful completion of my job. But from yesterday, I've been seeing a return code of 0000. I know this is not a show stopper, but I am little curious to know if there is any specific reason.

Is it because of any updates on the TSO in my shop? Any ideas?

Thanks
Kranthi
Back to top
View user's profile Send private message

enrico-sorichetti

Global Moderator


Joined: 14 Mar 2007
Posts: 10373
Location: italy

PostPosted: Tue Aug 14, 2012 8:57 pm    Post subject: Reply to: Return code 0000 oppose to 0
Reply with quote

why not ask Your support ?
we do not belong to Your organization and we have noo way to know what customization have been made

most probably it was not a simple TSO update, but a full zOS upgrate
Back to top
View user's profile Send private message
superk

Moderator Team Head


Joined: 26 Apr 2004
Posts: 4650
Location: Raleigh, NC, USA

PostPosted: Tue Aug 14, 2012 9:08 pm    Post subject: Reply to: Return code 0000 oppose to 0
Reply with quote

I noticed this when we went from z/OS v1R12 to z/OS v1R13.
Back to top
View user's profile Send private message
David Robinson

Active User


Joined: 21 Dec 2011
Posts: 182
Location: UK

PostPosted: Tue Aug 14, 2012 9:23 pm    Post subject:
Reply with quote

I've noticed this too on z/OS v1.13
Back to top
View user's profile Send private message
kranthikumarb

Active User


Joined: 02 Jan 2009
Posts: 115
Location: Hyderabad

PostPosted: Tue Aug 14, 2012 9:44 pm    Post subject:
Reply with quote

Thanks for the replies.

We was able to see S04E (the complete 4 chars) when I get notified after the job completes as well as in the CA-View. But we get a 0004 only in the CA-View and just 4 on the NOTIFY. I hope this has something to do with a return code which is just a numeric with out chars. IBM might have made a change something like zero suppression. Just a thought.

Skip replying if you think this is useless.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> TSO/ISPF All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Finding the plan when code compiled u... Ahemad DB2 1 Fri Dec 01, 2017 6:38 pm
No new posts Strange Code amitc23 COBOL Programming 6 Tue Nov 28, 2017 11:25 am
No new posts Speed-up/reduce CPU use of code prino PL/I & Assembler 0 Tue Sep 26, 2017 12:05 am
No new posts Return a Non Numeric value from REXX Learncoholic CLIST & REXX 3 Fri Sep 01, 2017 8:33 pm
This topic is locked: you cannot edit posts or make replies. how to code for GDG in Rexx cvnlynn CLIST & REXX 13 Wed Aug 09, 2017 9:13 pm

Facebook
Back to Top
 
Job Vacancies | Forum Rules | Bookmarks | Subscriptions | FAQ | Polls | Contact Us