Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

I have issue with Pages Corruption

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> DB2
View previous topic :: :: View next topic  
Author Message
Jeevankumar.Pochammala

New User


Joined: 04 May 2011
Posts: 7
Location: INDIA

PostPosted: Sat Jun 11, 2011 11:10 pm    Post subject: I have issue with Pages Corruption
Reply with quote

Hello All,
In one of my Application table some pages got corrupted and i tried to repair it by using Repair utility but still pages not freed from Corruption.
So can any one please let me know how recover the data from these corrupted pages.
Back to top
View user's profile Send private message

dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Sun Jun 12, 2011 1:56 am    Post subject:
Reply with quote

Hello and welcome to the forum,

How did these "pages" get corrupted?

Suggest you restore the table from the current backup.

Your best source of help is probably your dba. . .
Back to top
View user's profile Send private message
Jeevankumar.Pochammala

New User


Joined: 04 May 2011
Posts: 7
Location: INDIA

PostPosted: Sun Jun 12, 2011 12:02 pm    Post subject:
Reply with quote

Hello d.sch,

I had checked with DBA he tried to restore the data from Backup but still it is not recovering.

Please let me know if you have any other solutions

Thanks for your reply

Thanks
Jeevan
Back to top
View user's profile Send private message
Bill Woodger

DFSORT Moderator


Joined: 09 Mar 2011
Posts: 7307

PostPosted: Sun Jun 12, 2011 12:17 pm    Post subject:
Reply with quote

Seems a silly question, but have you tried an older backup? Maybe the "corruption" happened before the latest backup? In general, backup/restore puts things back a treat, that's why we do them - but the backup has to have "good" data on for you to restore to a "good" position for you.

What about Dick's question?

What are the symptoms (error messages) of the "corruption". Did you get any messages out of your repair attempt?

Basically, the more information about your problem that you can post, the better chance you have of a fix emerging.
Back to top
View user's profile Send private message
dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Sun Jun 12, 2011 5:41 pm    Post subject:
Reply with quote

Hello,

Were the backups ever tested to be correct/useful prior to now? If not, your environment is in serious trouble. . . Backups that have never been successfully restored are NOT backups - they are merely some media with questionable content. . .

Quote:
I had checked with DBA he tried to restore the data from Backup but still it is not recovering.
All this is is a longer way to say "it didn't work". What is probably the most useless thing to post is "it didn't work". This provides nothing than can be used to help you.

When something doesn't work, there are footprints (an abend, an error message, etc). You need to post the diagnostic information that was generated.

Is there possibly an image copy of the data? If there is, the data might be unloaded and re-loaded into the table.

If the table has been further damaged by people since the original problem, you may need to simply drop the table and re-create it.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> DB2 All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Execessive parameter issue Sumeendar JCL & VSAM 5 Mon Dec 19, 2016 4:35 pm
No new posts DFHRESPONSE returns issue divated CICS 3 Wed Nov 02, 2016 6:32 pm
No new posts Can sending 5 MB data between cobol p... Kevin Vaz CICS 12 Tue Oct 18, 2016 4:50 pm
No new posts REXX Screen not working due to LINKED... sundarkudos CLIST & REXX 1 Mon May 09, 2016 1:44 pm
No new posts Issue in sending zip file as mail att... ajithajt JCL & VSAM 8 Thu Apr 07, 2016 9:11 am


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us