Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

Job is not shown in Spool after execution

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> IBM Tools
View previous topic :: :: View next topic  
Author Message
Shanmukh

New User


Joined: 13 Sep 2008
Posts: 1
Location: India

PostPosted: Thu Feb 10, 2011 7:34 pm    Post subject: Job is not shown in Spool after execution
Reply with quote

Hi,

I had submitted a Job and the job executed successfully. When I went to spool and checked for the job ID i could not find the job.
Can anyone tell me the reason why the job is not shown in spool?

Regards,
Shanmukh.
Back to top
View user's profile Send private message

superk

Moderator Team Head


Joined: 26 Apr 2004
Posts: 4649
Location: Raleigh, NC, USA

PostPosted: Thu Feb 10, 2011 7:50 pm    Post subject: Reply to: Job is not shown in Spool after execution
Reply with quote

Maybe your MSGCLASS is defined incorrectly?
Back to top
View user's profile Send private message
gcicchet

Senior Member


Joined: 28 Jul 2006
Posts: 1703
Location: Australia

PostPosted: Fri Feb 11, 2011 4:55 am    Post subject:
Reply with quote

Hi,

check your SYSLOG and see what happened to your job.


Gerry
Back to top
View user's profile Send private message
Robert Sample

Global Moderator


Joined: 06 Jun 2008
Posts: 8117
Location: East Dubuque, Illinois, USA

PostPosted: Fri Feb 11, 2011 5:13 am    Post subject:
Reply with quote

Question 1: how do you know the job executed successfully if you cannot see it on the spool?

Question 2: are you aware that a syntax error on the JOB card will cause the job to flush without attempting to execute -- one possible reason for it not to show up on the spool?

Question 3: do you know which MSGCLASS to specify? Different sites have different standards and some sites use a message class to indicate you don't want the output, so it is deleted immediately - a second possible reason for it not to show up on the spool.

Question 4: have you talked to your site support group, team leader, or coworkers to determine if there are site requirements for job names that you may not have followed -- a third possible reason for it not to show up on the spool?

That should get you started -- there are other possible reasons a job would not show up on the spool, of course.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> IBM Tools All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
This topic is locked: you cannot edit posts or make replies. SDSF multiple spool datasets extracte... PJAlarcon CLIST & REXX 1 Fri Apr 21, 2017 10:50 pm
No new posts REXX cdoe to purge a JOB from spool a... Sulabh Agrawal CLIST & REXX 11 Thu Mar 09, 2017 11:36 am
This topic is locked: you cannot edit posts or make replies. JCL MULTIPLE STEP EXECUTION QUERY Susanta JCL & VSAM 18 Sat Jul 30, 2016 1:17 pm
No new posts output DDname JESMSGLG job during exe... italo_pm TSO/ISPF 16 Tue Jun 21, 2016 11:13 am
No new posts Report output in Spool amitc23 JCL & VSAM 4 Tue Apr 26, 2016 4:32 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us