Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

Problem with the SUBMIT command

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> TSO/ISPF
View previous topic :: :: View next topic  
Author Message
tecnokrat
Warnings : 1

Active User


Joined: 22 May 2009
Posts: 158
Location: Bangalore

PostPosted: Thu Jan 20, 2011 12:55 pm    Post subject: Problem with the SUBMIT command
Reply with quote

Hi,
I'm facing problem in submitting a JOB thru the REXX program.

Code:

    SELECT
    WHEN REGION = DEV1 THEN SUBMIT 'MYID.REXXPGMS(MEM1)'
    WHEN REGION = DEV2 THEN SUBMIT 'MYID.REXXPGMS(MEM2)'
    WHEN REGION = TEST  THEN SUBMIT 'MYID.REXXPGMS(MEM3)'
   END
 
 


When the rexx reaches this statement it gives me RC(12)
with the following message
Quote:
IKJ56269I DATA SET MYID.REXXPGMS NOT FOUND


Do i need to open the dataset before the submit command is reached or is it ok with if the Dataset is not opened with any exclusive command.
Back to top
View user's profile Send private message

vasanthz

Global Moderator


Joined: 28 Aug 2007
Posts: 1456
Location: Azeroth

PostPosted: Thu Jan 20, 2011 1:23 pm    Post subject:
Reply with quote

Hi,
Try this out.

Code:
THEN ADDRESS TSO "SUBMIT  'MYID.REXXPGMS(MEM1)'"

Hope it helps.
Back to top
View user's profile Send private message
superk

Moderator Team Head


Joined: 26 Apr 2004
Posts: 4648
Location: Raleigh, NC, USA

PostPosted: Thu Jan 20, 2011 1:56 pm    Post subject: Reply to: Problem with the SUBMIT command
Reply with quote

SUBMIT is a TSO command, not a REXX instruction. Didn't that statement look odd to you in your ISPF Editor?
Back to top
View user's profile Send private message
tecnokrat
Warnings : 1

Active User


Joined: 22 May 2009
Posts: 158
Location: Bangalore

PostPosted: Thu Jan 20, 2011 2:22 pm    Post subject:
Reply with quote

Thanks Vasanthz !!!! it worked. icon_smile.gif
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> TSO/ISPF All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts SYMNAMES problem jacobdng DFSORT/ICETOOL 7 Thu Dec 22, 2016 7:47 am
No new posts What is the command to check MODE of ... rohanthengal CLIST & REXX 7 Fri Nov 18, 2016 1:48 pm
No new posts Problem in writing Output file vickey_dw COBOL Programming 5 Mon Nov 14, 2016 11:14 pm
No new posts Problem in Running Query via JCL vickey_dw DB2 3 Tue Oct 18, 2016 11:11 pm
No new posts SDSF Command Avtrix CLIST & REXX 4 Fri Sep 30, 2016 11:13 am


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us