Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

IBM Debug toll Issue

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> IBM Tools
View previous topic :: :: View next topic  
Author Message
Susanta

Active User


Joined: 17 Nov 2009
Posts: 118
Location: India

PostPosted: Thu Dec 23, 2010 11:31 am    Post subject: IBM Debug toll Issue
Reply with quote

Hi
I am new to IBM DEbug tool and getting problem with listing files.

I am using Enterprise COBOL for z/OS with LE enabled.

Whether i need to use EQADEBUG or EQALANGX or SYSDEBUG as listing file.

And how can i generate these files.
Currently my compiler generates a listing file not sure if i can use it.

My compiler uses a proc named NDVRC1 .

Currently i am getting below message
<< Source or Listing data is not available, or the CU was not compiled with the correct compile options. >>

Please help.
Back to top
View user's profile Send private message

don.leahy

Active Member


Joined: 06 Jul 2010
Posts: 642
Location: Whitby, ON, Canada

PostPosted: Thu Dec 23, 2010 6:21 pm    Post subject:
Reply with quote

SYSDEBUG is the easiest way. If you have a SYSDEBUG dd defined in your compile JCL, the compiler will store the name of the SYSDEBUG file in the load module. This makes it easy for Debug Tool to find the data set at execution time.
Back to top
View user's profile Send private message
vishnu.priya

New User


Joined: 28 Nov 2007
Posts: 11
Location: hyderabad

PostPosted: Thu Feb 03, 2011 5:42 pm    Post subject: Reply to: IBM Debug toll Issue
Reply with quote

how to define the sysdebug in compile jcl.Am using Endevor , I also use foreground method to stage my component.
Please let me know how can I proceed.

Thanks,
Priya
Back to top
View user's profile Send private message
dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Thu Feb 03, 2011 9:15 pm    Post subject:
Reply with quote

Hello,

You should talk with the people who support Endevor and the compile processes on your system.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> IBM Tools All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Execessive parameter issue Sumeendar JCL & VSAM 5 Mon Dec 19, 2016 4:35 pm
No new posts DFHRESPONSE returns issue divated CICS 3 Wed Nov 02, 2016 6:32 pm
No new posts Can sending 5 MB data between cobol p... Kevin Vaz CICS 12 Tue Oct 18, 2016 4:50 pm
No new posts REXX Screen not working due to LINKED... sundarkudos CLIST & REXX 1 Mon May 09, 2016 1:44 pm
No new posts Issue in sending zip file as mail att... ajithajt JCL & VSAM 8 Thu Apr 07, 2016 9:11 am


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us