Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

RBA Access error for VSAM files

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> JCL & VSAM
View previous topic :: :: View next topic  
Author Message
sasikumar1984

Active User


Joined: 02 Jul 2007
Posts: 109
Location: Chennai - India

PostPosted: Sat Jun 12, 2010 8:44 am    Post subject: RBA Access error for VSAM files
Reply with quote

hi,

I just started using VSAM files for my new project... i saw some jobs in production abending due to RBA access error... As per instructions, we are just restarting the job from abended step and it is going fine when we restart... Of course sometimes it goes down multiple times with same issue... but after some number of attempts it will go fine...

Here no one knows reason for that.. all r simply restarting.... i just like to know, what is RBA access error and why it is going fine when we restart it...???
Back to top
View user's profile Send private message

dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Sat Jun 12, 2010 9:49 am    Post subject:
Reply with quote

Hello,

How have you determined there is an "RBA access error"?

With no more information, my guess is there is some program error. . .
Back to top
View user's profile Send private message
sasikumar1984

Active User


Joined: 02 Jul 2007
Posts: 109
Location: Chennai - India

PostPosted: Sat Jun 12, 2010 10:06 am    Post subject: Reply to: RBA Access error for VSAM files
Reply with quote

Thanks for your reply Dick...

Its happening when taking backup using IDCAMS utility.... my doubt is if there is an issue with the VSAM file or the utility we are using... why it is going fine when restaring the job??
Back to top
View user's profile Send private message
dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Sat Jun 12, 2010 10:25 am    Post subject:
Reply with quote

Hello,

What exactly is presented to show the error? It will help if you post the IDCAMS control statements and the printed output from a problem run.

I suspect that IDCAMS is working as it should. . . You might ask your tech support to look for any fixes for this problem with IDCAMS.

There may be a problem with the file or there may be a timing issue.
Back to top
View user's profile Send private message
expat

Global Moderator


Joined: 14 Mar 2007
Posts: 8593
Location: Back in jolly old England

PostPosted: Sat Jun 12, 2010 11:36 am    Post subject:
Reply with quote

As Dick has said, you need to post the output from a failed run to get any real help.

- Psychic day cancelled due to unforseen circumstances icon_lol.gif
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> JCL & VSAM All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Fail to change physical VSAM filename... jacobdng CICS 6 Fri Jan 20, 2017 12:36 pm
No new posts how to recover an uncataloged VSAM da... archanamuthukrishnan All Other Mainframe Topics 3 Wed Jan 11, 2017 6:18 pm
No new posts OO COBOL compile error Virendra Shambharkar COBOL Programming 3 Tue Jan 10, 2017 6:05 pm
No new posts Underlying DB2 VSAM LDS - SMF recording vasanthz All Other Mainframe Topics 6 Thu Jan 05, 2017 4:20 am
No new posts S922 Error yuvan ABENDS & Debugging 3 Fri Dec 02, 2016 6:58 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us