Portal | Manuals | References | Downloads | Info | Programs | JCLs | Mainframe wiki | Quick Ref
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Profile Log in to check your private messages Log in
 
Getting U0254 Abend

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> IMS DB/DC
View previous topic :: :: View next topic  
Author Message
chanti

New User


Joined: 22 Nov 2008
Posts: 29
Location: hyderabad

PostPosted: Tue May 18, 2010 11:10 am    Post subject: Getting U0254 Abend
Reply with quote

Hi,

While im trying to insert some data into the PSB, iam getting the following abend

+DFS629I IMS BATCH REGION ABEND- IMS 0254
+DFS0730I UNABLE TO OPEN DATA SET WITH DDNAME XXXXXX FOR REASON I,31,

How to solve that abend, i have no clue ! I tried by creating the Dataset with other Volumes(Assuming it might be space problem in the volumes) but no luck.

Thanks,
Chanti
Back to top
View user's profile Send private message

PeterHolland

Global Moderator


Joined: 27 Oct 2009
Posts: 2446
Location: Netherlands, Amstelveen

PostPosted: Tue May 18, 2010 11:37 am    Post subject:
Reply with quote

You could have found the next info yourself :


I, 31
An attempt was made to open a VSAM data set associated with a PCB, which has a processing option other than L, and the data set is empty.
Programmer response: Use a PCB with processing option L to perform the initial loading of a database. When developing the JCL, use the following procedure:
1.step01 Delete or define KSDS data set.
2.step02 Run PRECO to rebuild ILE and the Primary Index data set.
Note: If you cancel the job while in step02, rerun the entire job starting from step01. Do not restart in step02
Back to top
View user's profile Send private message
chanti

New User


Joined: 22 Nov 2008
Posts: 29
Location: hyderabad

PostPosted: Tue May 18, 2010 12:38 pm    Post subject: Reply to: Getting U0254 Abend
Reply with quote

Hi Peter,

Your info really helped!
i didn't do the initial loading of a database.
Now, I have initialized the database with PROCOPT as L, its working!

Thanks,
Chanti.
Back to top
View user's profile Send private message
PeterHolland

Global Moderator


Joined: 27 Oct 2009
Posts: 2446
Location: Netherlands, Amstelveen

PostPosted: Tue May 18, 2010 12:44 pm    Post subject:
Reply with quote

Cheers.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> IMS DB/DC All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts How to force a select query to abend neo4u DB2 2 Mon Apr 23, 2018 1:36 pm
No new posts Need help with 002-030 ABEND in TSO R... Terry Tallian TSO/ISPF 0 Sat Mar 17, 2018 1:13 am
No new posts Need help with ABEND RC=S806 RSN=4 an... chong.zhou All Other Mainframe Topics 3 Fri Feb 09, 2018 12:17 am
No new posts ASP3 ABEND IN CICS Vedant CICS 0 Fri Oct 20, 2017 3:18 pm
No new posts C03 ABEND sjiraga PL/I & Assembler 1 Thu Jun 01, 2017 4:51 pm

Facebook
Back to Top
 
Job Vacancies | Forum Rules | Bookmarks | Subscriptions | FAQ | Polls | Contact Us