Portal | Manuals | References | Downloads | Info | Programs | JCLs | Mainframe wiki | Quick Ref
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Profile Log in to check your private messages Log in
 
XMITIP and Surrogate Id

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> All Other Mainframe Topics
View previous topic :: :: View next topic  
Author Message
dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Wed Apr 28, 2010 9:57 pm    Post subject: XMITIP and Surrogate Id
Reply with quote

Hello,

Production jobs are run under a surrogate id rather than the id of the operator/scheduler. As it happens, the surrogate id has permissions, but was not actually created as a tso user-id.

All XMITIP processes that use the surrogate id have this as the first line of the SYSTSPRT output:
IKJ56644I NO VALID TSO USERID, DEFAULT USER ATTRIBUTES USED
This does not appear to cause anything other than a bit of confusion. . .

Until now. . .

Recently, due to increasing volume, an XMITIP step was changed to ZIP the file to be attached and the compression is failing due to a dataset "mis-match". The XMITIP output now contains:
XMITIP: Using ZIP: INFOZIP
XMITIP: zip file as: 'PRDBATCH.z02321.THEFILE.txt'

followed by:
IRX0555E The input or output file XM098152 is not allocated.
So far, i've not found why XM098152 is not allocated. . . I'll continue chasing thru the XMITIP execs.

Has anyone seen this behavior? Any thoughts?

Thanks,

d
Back to top
View user's profile Send private message

lbdyck

New User


Joined: 02 Jun 2003
Posts: 4
Location: Walnut Creek, California, USA

PostPosted: Thu May 06, 2010 1:42 am    Post subject: XMITIP and High Level Qualifier
Reply with quote

When the default dataset prefix or high level qualifier is not one that allows the allocation of datasets use the XMITIP HLQ keyword. That should resolve your issue.

Good luck
Back to top
View user's profile Send private message
dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Thu May 06, 2010 4:42 am    Post subject: Reply to: XMITIP and Surrogate Id
Reply with quote

Thank you icon_smile.gif

I will ask "them" (the folks who brought this my way) if they will run a test.

What they did earlier today was to request the service bureau actually create the id. . . The early testing has gone well from what i learned late this afternoon.

Thanks again,

d
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> All Other Mainframe Topics All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts XMITIP sends it out. Can it copy on l... Rommel Dayon Rustia IBM Tools 0 Tue Sep 05, 2017 10:16 am
No new posts Splitting of single report to seperat... abdulrafi TSO/ISPF 7 Mon Mar 27, 2017 3:59 pm
No new posts XMITIP, sending the mainframe data in... dharmaraok TSO/ISPF 7 Fri Aug 21, 2015 4:29 pm
No new posts JCL -> Rexx -> XMITIP : Doesnt ... enrico-sorichetti CLIST & REXX 2 Thu Aug 06, 2015 11:09 pm
No new posts Need help for XMITIP graswant IBM Tools 7 Wed Apr 23, 2014 2:37 pm

Facebook
Back to Top
 
Job Vacancies | Forum Rules | Bookmarks | Subscriptions | FAQ | Polls | Contact Us