Portal | Manuals | References | Downloads | Info | Programs | JCLs | Mainframe wiki | Quick Ref
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Profile Log in to check your private messages Log in
 
TWS OPC doesn't issue WTO when running operations from CP

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> IBM Tools
View previous topic :: :: View next topic  
Author Message
Radek Jalovy

New User


Joined: 14 Mar 2009
Posts: 7
Location: Czech Republic

PostPosted: Mon Nov 16, 2009 3:05 am    Post subject: TWS OPC doesn't issue WTO when running operations from CP
Reply with quote

Hello everybody,
I have very suspicious problem. I have done all neccessary updates of SA and OPC to be able to submit operations for NVxx workstations and be able to stop/start running instances defined in SA.
The problem is if I create the LTP and then Current Plan and when the operations are submitted it is not working. OPC does not enter the exit, does not issue the WTO for SA and .. it just doesn't do anything.
But when I add application with the same operation to current plan manually (by MCP) or restart application manually which have been completed in CP, it works fine. It enters the exit, it stops the required instance. Very strange.. do you have any ideas?
Back to top
View user's profile Send private message

Radek Jalovy

New User


Joined: 14 Mar 2009
Posts: 7
Location: Czech Republic

PostPosted: Mon Nov 16, 2009 4:26 am    Post subject:
Reply with quote

I just wanted to add that batch operations are being submitted normally no matter if they are added to current plan manually or by extending.
Back to top
View user's profile Send private message
PeterHolland

Global Moderator


Joined: 27 Oct 2009
Posts: 2453
Location: Netherlands, Amstelveen

PostPosted: Mon Nov 16, 2009 11:46 am    Post subject:
Reply with quote

Did you start the PPI receivers? The "request" receiver handles the OPC exit
status updates and requests?

Is a tracker started?

Can you see your application if you issue INGOPC?

Can you modify the CPL with INGOPC?

Did you follow the guide lines in "OPC Automation Programmers Reference"
SC33-7046-03 ?

Can you show samples of your OPC application definitions?
Back to top
View user's profile Send private message
Radek Jalovy

New User


Joined: 14 Mar 2009
Posts: 7
Location: Czech Republic

PostPosted: Mon Nov 16, 2009 11:52 am    Post subject:
Reply with quote

Did you start the PPI receivers? The "request" receiver handles the OPC exit
status updates and requests?


Yes.. they are started

Is a tracker started?

Tracker is started too. Controller is OPCC and tracker as OPCT

Can you see your application if you issue INGOPC? Can you modify the CPL with INGOPC?

Yes .. without any problems.


Did you follow the guide lines in "OPC Automation Programmers Reference"
SC33-7046-03 ?


Positive

Can you show samples of your OPC application definitions?

I can but I don't think it helps. As I said it is working normally if I add application to current plan manually or restart completed (abended) application. But when you schedule it by extending CP then it is not working!!
Back to top
View user's profile Send private message
PeterHolland

Global Moderator


Joined: 27 Oct 2009
Posts: 2453
Location: Netherlands, Amstelveen

PostPosted: Mon Nov 16, 2009 12:57 pm    Post subject:
Reply with quote

NVxx workstations talk with NetView via the EQQU007 exit when a status
change occurs, e.g. Arrival, Ready.
WTO's will not be processed as far as i remember.

For extending the CP read Extending the Daily Plan chapter 11 in the before mentioned manual, maybe you didnt define an operation on a dummy workstation as a predecessor to the NVxx.

Before i forget are OPCACMD entries defined in the automation policy
database?
Back to top
View user's profile Send private message
Radek Jalovy

New User


Joined: 14 Mar 2009
Posts: 7
Location: Czech Republic

PostPosted: Tue Nov 24, 2009 5:01 am    Post subject:
Reply with quote

You were right again... there were no dummy operations!! I had to skip that in manual when I was fighting the exhaustion icon_smile.gif
Thanks a lot
Back to top
View user's profile Send private message
PeterHolland

Global Moderator


Joined: 27 Oct 2009
Posts: 2453
Location: Netherlands, Amstelveen

PostPosted: Tue Nov 24, 2009 12:21 pm    Post subject:
Reply with quote

You are welcome.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> IBM Tools All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
This topic is locked: you cannot edit posts or make replies. Issue in suppressing leading zeros &a... Vijay_Sirisha COBOL Programming 21 Thu Jun 07, 2018 8:01 pm
No new posts CICS-MQ connection setup issue kaushikv CICS 3 Wed Mar 21, 2018 8:10 pm
No new posts Need Help!!CEE library issue while br... kaushikv CICS 9 Fri Mar 09, 2018 6:06 pm
No new posts OLDS frozen in BACKOUT status when On... lind sh IMS DB/DC 3 Tue Feb 13, 2018 7:12 pm
No new posts Tape file issue abdulrafi JCL & VSAM 2 Thu Feb 08, 2018 12:01 pm

Facebook
Back to Top
 
Job Vacancies | Forum Rules | Bookmarks | Subscriptions | FAQ | Polls | Contact Us