Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

FILEXFER service failed because there is no connection to WS

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> TSO/ISPF
View previous topic :: :: View next topic  
Author Message
chowdhrykapildev

New User


Joined: 05 Aug 2009
Posts: 44
Location: Hyderabad

PostPosted: Tue Sep 29, 2009 8:53 pm    Post subject: FILEXFER service failed because there is no connection to WS
Reply with quote

I'm trying to run a XFER command through my pgm and I'm getting the following error.

ISPX010

Transfer failed
The FILEXFER service failed because there is no connection to the
workstation.

Current dialog statement:
ISPEXEC FILEXFER WS(WSFN) HOST(OUTFILE) TO(HOST)

The following is my code:
Code:

IPADDR = '9.184.106.106'                                         
 OUTFILE = 'IN16592.SRM.REXXPDS'                                   
 WSFN = 'C:\srm\file183.pds.xmit'                                 
           /* WSCON - CONNECT TO THE WSA */                       
 "ISPEXEC WSCON IP(IPADDR) CODEPAGE(0037) CHARSET(0697) NOGUIDSP" 
 IF RC>0 THEN                                                     
 "ISPEXEC FILEXFER WS(WSFN) HOST(OUTFILE) TO(HOST)"               
 IF RC>0 THEN                                                     
 SAY SUCCESS
Back to top
View user's profile Send private message

Pedro

Senior Member


Joined: 01 Sep 2006
Posts: 2058
Location: Silicon Valley

PostPosted: Tue Sep 29, 2009 9:09 pm    Post subject: Reply to: FILEXFER service failed because there is no connec
Reply with quote

I do not understand these statements:
Code:
"ISPEXEC WSCON IP(IPADDR) CODEPAGE(0037) CHARSET(0697) NOGUIDSP"
IF RC>0 THEN
"ISPEXEC FILEXFER WS(WSFN) HOST(OUTFILE) TO(HOST)"

Why do the FILEXFER when WSCON return code is non-zero? What return code are you getting?
Back to top
View user's profile Send private message
superk

Moderator Team Head


Joined: 26 Apr 2004
Posts: 4649
Location: Raleigh, NC, USA

PostPosted: Tue Sep 29, 2009 10:32 pm    Post subject: Reply to: FILEXFER service failed because there is no connec
Reply with quote

And, is the Workstation Agent active and is that the correct TCP/IP address for it?
Back to top
View user's profile Send private message
chowdhrykapildev

New User


Joined: 05 Aug 2009
Posts: 44
Location: Hyderabad

PostPosted: Wed Sep 30, 2009 12:34 pm    Post subject: Reply to: FILEXFER service failed because there is no connec
Reply with quote

Hi all,

The command
"ISPEXEC WSCON IP(IPADD) CODEPAGE(0037) CHARSET(0697) NOGUIDSP"
will establish the connection. Yes the connection agent is active.

Actually I am trying to receive a file from mainframes to desktop. And I am using this command.
WSFN = 'C:\DOCUMENTS AND SETTINGS\FTP'
OUTFILE =DSNAME /* the file which i want from mainframes */
"ISPEXEC FILEXFER WS(WSFN) HOST(OUTFILE) TO(WS)"

But its not working.

Kindly suggest me on this...
Back to top
View user's profile Send private message
Pedro

Senior Member


Joined: 01 Sep 2006
Posts: 2058
Location: Silicon Valley

PostPosted: Wed Sep 30, 2009 7:30 pm    Post subject: Reply to: FILEXFER service failed because there is no connec
Reply with quote

Quote:
Why do the FILEXFER when WSCON return code is non-zero? What return code are you getting?


My earlier question was not about WSCON, but about the IF statement. I question why you issue the FILEXFER only after nonzero return code. It seems like it is should be done on rc=0.

Nor did you answer what return code you are getting.

Nor did you answer SuperK's question about the IP address being current.
Back to top
View user's profile Send private message
chowdhrykapildev

New User


Joined: 05 Aug 2009
Posts: 44
Location: Hyderabad

PostPosted: Thu Oct 01, 2009 6:17 pm    Post subject: Reply to: FILEXFER service failed because there is no connec
Reply with quote

Hi Pedro,

Yes I have made some corrections and it went fine. The next problem I am seeing is posted as "extract member name for a given PDS".
I have explained about my problem in detail in that post. I kindly request you all to have a look into it.

Thanks a lot in advance.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> TSO/ISPF All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts RDz Json restful service Kevin Vaz IBM Tools 4 Thu Jun 29, 2017 10:44 pm
No new posts Any Recommended Timesharing service c... johnmull All Other Mainframe Topics 0 Mon Jan 02, 2017 11:39 am
No new posts FTP - JCL failed while passing FTP co... Suneetha1612 JCL & VSAM 12 Wed Nov 16, 2016 7:33 pm
No new posts changing z/os unicode conversion service meykh2014 All Other Mainframe Topics 0 Tue Jul 12, 2016 10:49 am
No new posts How to sending system service request... lind sh IMS DB/DC 5 Sun Apr 10, 2016 12:02 am


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us