Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

I have a problem with #SCC code

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> CA Products
View previous topic :: :: View next topic  
Author Message
ecibarra

New User


Joined: 06 Jun 2007
Posts: 2
Location: Argentina

PostPosted: Fri Apr 17, 2009 7:24 pm    Post subject: I have a problem with #SCC code
Reply with quote

My job have:
//JS010 EXEC PGM=WAAPLINK,
// PARM='IDCAMS,RC=8'
//*
#SCC,COND=(7,LT,JS010)
#JEND
//*
//*
Step JS010 finished with RC=0, but the next step finished with RC=0004 and the job didn't abend.
This is the Job Cpu definition in CA7:
EXECUTION: MAINID: ALL INSERT-RMS: Y COND-CODE: 0 RO: #S
DONT SCHEDULE -- BEFORE: 00000 0000 AFTER: 99999 0000
Cuold you help me please ?
Back to top
View user's profile Send private message

dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Fri Apr 17, 2009 9:35 pm    Post subject:
Reply with quote

Hello and welcome to the forum,

Quote:
but the next step finished with RC=0004 and the job didn't abend

Suggest you work with your scheduling people to define this.
Back to top
View user's profile Send private message
expat

Global Moderator


Joined: 14 Mar 2007
Posts: 8593
Location: Back in jolly old England

PostPosted: Sat Apr 18, 2009 12:10 pm    Post subject:
Reply with quote

The #SCC defined in the job will take precedence over that defined in the panel at job definition time.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> CA Products All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Job failing with USER = 4093 REASON C... Pradeepa S ABENDS & Debugging 1 Wed May 17, 2017 3:35 pm
No new posts COBOL Code Parsers and Lineage Establ... balimanja COBOL Programming 2 Tue May 02, 2017 3:30 am
No new posts Cobol upgrade - source code missing f... gthmrj IBM Tools 1 Wed Apr 26, 2017 6:04 pm
No new posts Strings with double quotes having pro... raja Arumugam All Other Mainframe Topics 11 Thu Mar 30, 2017 10:34 am
No new posts Problem reading GTF trace output danik56 ABENDS & Debugging 7 Thu Mar 16, 2017 1:02 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us