Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

With XPED records are writing to file ,bt for normal its not

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> Compuware & Other Tools
View previous topic :: :: View next topic  
Author Message
sanjayk

New User


Joined: 10 Mar 2009
Posts: 1
Location: Hyderbad

PostPosted: Wed Mar 18, 2009 3:12 pm    Post subject: With XPED records are writing to file ,bt for normal its not
Reply with quote

when i exped the program , records are writing in to file . but for normal submission the records are not writing in to file

can any one suggest me how can i try this
Back to top
View user's profile Send private message

Robert Sample

Global Moderator


Joined: 06 Jun 2008
Posts: 8117
Location: East Dubuque, Illinois, USA

PostPosted: Wed Mar 18, 2009 4:53 pm    Post subject:
Reply with quote

CICS? Batch? COBOL? Assembler? PL/1? C? I'm not sure you could have been more cryptic in your request if you had deliberately tried.
Back to top
View user's profile Send private message
Mathiv Anan

Active User


Joined: 23 Jul 2008
Posts: 106
Location: USA

PostPosted: Wed Mar 18, 2009 5:32 pm    Post subject:
Reply with quote

I dont think it is writing while Xpediting the program.

You can see the WRITE statement getting executed but i think actually its not writing into the file.

Did you try checking file status code after the WRITE statement is executed while Xpediting?
Back to top
View user's profile Send private message
Terry Heinze

JCL Moderator


Joined: 14 Jul 2008
Posts: 1249
Location: Richfield, MN, USA

PostPosted: Wed Mar 18, 2009 10:01 pm    Post subject:
Reply with quote

A common reason causing a program to behave differently under Xpediter and without Xpediter is different load libraries. When using Xpediter, you must define the same load libraries that are used when executing the program without Xpediter.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> Compuware & Other Tools All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
This topic is locked: you cannot edit posts or make replies. Fetching data from BAI File arunsoods JCL & VSAM 1 Wed Jul 19, 2017 4:28 pm
No new posts Write out NODUPS but just from one file Jay Villaverde DFSORT/ICETOOL 8 Fri Jul 14, 2017 12:44 am
No new posts How to add header with Date(YYMMDD) i... Rajan Moorthy DFSORT/ICETOOL 2 Thu Jul 06, 2017 11:44 pm
No new posts How to generate a new unique Input fi... for1ranjith CLIST & REXX 11 Sat Jul 01, 2017 12:09 pm
No new posts Writing a file using online program grvtomar PL/I & Assembler 3 Fri Jun 30, 2017 1:06 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us