Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

Vsam error 168 when Iam trying to repro it

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> JCL & VSAM
View previous topic :: :: View next topic  
Author Message
Sravanthi modugu

New User


Joined: 28 May 2008
Posts: 2
Location: Bangalore

PostPosted: Fri May 30, 2008 12:59 pm    Post subject: Vsam error 168 when Iam trying to repro it
Reply with quote

Hi,

I have created a new VSAM file and when Iam trying to repro it frm the sequential file I am getting the VSAM error 168.

Please let me know what could be the problem?


Thanks in Advance,
Sravanthi M
Back to top
View user's profile Send private message

enrico-sorichetti

Global Moderator


Joined: 14 Mar 2007
Posts: 10210
Location: italy

PostPosted: Fri May 30, 2008 1:04 pm    Post subject: Reply to: Vsam error 168
Reply with quote

what about giving a bit more of info and posting ...

JCL

OUTPUT of the run
Back to top
View user's profile Send private message
Sravanthi modugu

New User


Joined: 28 May 2008
Posts: 2
Location: Bangalore

PostPosted: Fri May 30, 2008 1:31 pm    Post subject: Reply to: Vsam error 168
Reply with quote

Please find the attachment for the Job and output details

for the first time I have created the KSDS and fr each run I am deleting the existing definition and Redefining.

The vsam file is getting creating each time but when it comes to opening of a file for reproing it's giving the error


Thanks,
Sravanthi M
Back to top
View user's profile Send private message
enrico-sorichetti

Global Moderator


Joined: 14 Mar 2007
Posts: 10210
Location: italy

PostPosted: Fri May 30, 2008 1:44 pm    Post subject: Reply to: Vsam error 168
Reply with quote

please do not use attachments, they are just a waste of space and many people
are not able to open them

paste things with the code tags ( they are also much more readable )

the jcl as posted is wrong
it' s a bad practice to have dd pointing to datasets which are going to be deleted and defined in the same step

as a first debugging step try to run the define and the repro as two different steps
or for the repro insted of using the outfile use the outdataset

since it' s a bad practice ...
I never used the outfile in the same step as the delete/define
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> JCL & VSAM All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts how to recover an uncataloged VSAM da... archanamuthukrishnan All Other Mainframe Topics 3 Wed Jan 11, 2017 6:18 pm
No new posts OO COBOL compile error Virendra Shambharkar COBOL Programming 3 Tue Jan 10, 2017 6:05 pm
No new posts Underlying DB2 VSAM LDS - SMF recording vasanthz All Other Mainframe Topics 6 Thu Jan 05, 2017 4:20 am
No new posts S922 Error yuvan ABENDS & Debugging 3 Fri Dec 02, 2016 6:58 pm
No new posts Invoke Webservice Fails with DFHPI100... divated CICS 2 Thu Nov 24, 2016 5:57 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us