Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

Debug cobol code using Xpediter

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> ABENDS & Debugging
View previous topic :: :: View next topic  
Author Message
the-end-user1

New User


Joined: 30 Jan 2008
Posts: 4
Location: Chennai

PostPosted: Wed Jan 30, 2008 10:42 pm    Post subject: Debug cobol code using Xpediter
Reply with quote

Hi all,

Am trying to debug my cobol code using Xpeditor. I first allocated the DDIO files. But not sure how to execute the source program.

I also tried option 2 of the main menu "2 TSO - Debug programs interactively under TSO" providing the run-jcl in the "File List/JCL Member" location, but still the program is not executed. I dont get where i have gone wrong.

Can some please help me out with the procedure to execute the cobol program through xpeditor in online mode.

Thanks and Regards,
Pal.
Back to top
View user's profile Send private message

dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Wed Jan 30, 2008 11:08 pm    Post subject:
Reply with quote

Hello Pal and welcome to the forums,

To learn how to do this on your system, i'd suggest you talk with whoever supports Xpeditor on your system. They will know everything you need for that system.
Back to top
View user's profile Send private message
the-end-user1

New User


Joined: 30 Jan 2008
Posts: 4
Location: Chennai

PostPosted: Wed Jan 30, 2008 11:18 pm    Post subject:
Reply with quote

Hi,

I got the error location. Its because of the value not provided to the "Phone Number" field while allocating the list of files.

Once i filled that value, it worked fine.

Thanks and Regards,
Pal.
Back to top
View user's profile Send private message
dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Thu Jan 31, 2008 12:35 am    Post subject: Reply to: Debug cobol code using Xpediter
Reply with quote

You're welcome icon_smile.gif

Thank you for posting the solution.

d
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> ABENDS & Debugging All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Job failing with USER = 4093 REASON C... Pradeepa S ABENDS & Debugging 1 Wed May 17, 2017 3:35 pm
This topic is locked: you cannot edit posts or make replies. Cobol GUI (like Editor) Kala Mainframe COBOL Programming 14 Wed May 10, 2017 12:30 pm
No new posts IMS T-Pipe queue counts in a COBOL Pr... Siva NKK Kothamasu IMS DB/DC 0 Tue May 09, 2017 6:31 pm
No new posts COBOL Code Parsers and Lineage Establ... balimanja COBOL Programming 2 Tue May 02, 2017 3:30 am
No new posts Cobol upgrade - source code missing f... gthmrj IBM Tools 1 Wed Apr 26, 2017 6:04 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us