Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

JCL -FTP CC=2424 error?

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> JCL & VSAM
View previous topic :: :: View next topic  
Author Message
Girishm

New User


Joined: 09 Mar 2005
Posts: 35
Location: Mysore

PostPosted: Tue May 10, 2005 2:44 pm    Post subject: JCL -FTP CC=2424 error?
Reply with quote

One of my Mainframe Job transmits data to FTP, where it sometimes goes down with CC=2424 error. Job will run to good EOJ after sometime, when restarted in step. I see no problem with my job as it's a daily running job, going down only at odd hours, and odd days.

Could any of you let me know, why this error, anything can be done (from my job point of view) to prevent this ABEND? Any info on this ASAP is very much welcome.

Thanks in advance,
_________________
GM
Back to top
View user's profile Send private message

MGIndaco

Active User


Joined: 10 Mar 2005
Posts: 432
Location: Milan, Italy

PostPosted: Wed May 18, 2005 8:10 pm    Post subject:
Reply with quote

I think that you try to connect the wrong port.
Back to top
View user's profile Send private message
MGIndaco

Active User


Joined: 10 Mar 2005
Posts: 432
Location: Milan, Italy

PostPosted: Wed May 18, 2005 8:15 pm    Post subject:
Reply with quote

Ops. I'm sorry....
I gave you a wrong information. Do not consider it!
2424 is the CC of JCl but you have also this ftp error?
Code:
EZA1685W Invalid local file identifier             
EZA1735I FTP Return Code = 27000, Error Code = 00002
Back to top
View user's profile Send private message
Girishm

New User


Joined: 09 Mar 2005
Posts: 35
Location: Mysore

PostPosted: Tue Jun 07, 2005 2:06 pm    Post subject:
Reply with quote

Thanks for the info MGI..

No, I get the below FTP error code
recv error from getNextReply - EDC8121I Connection reset. (errno2=0x766

Connection with cheetah.FED.COM terminated
*** I can't open a data-transfer connection:
Std Return Code = 27000, Error Code = 00010

Any info on this asap, is welcome.
I wanted to know, can this problem arise because of JCL setup or FTP related issues. Because when I restart the job after sometime, it runs to good EOJ, without any changes?

Thanks in advance.
______________
GM
Back to top
View user's profile Send private message
radhakrishnan82

Active User


Joined: 31 Mar 2005
Posts: 436
Location: chennai, India

PostPosted: Wed Jun 08, 2005 2:09 pm    Post subject:
Reply with quote

This is definitely FTP related issue.
Your connection TO SERVER may be down at the time.So it caused the abort.The server may be UP at the time when you restart the job.Hence the restarted job ran successfully and the FTP was successfull.
Are you running a scheduled job or non-scheduled job?
Back to top
View user's profile Send private message
Girishm

New User


Joined: 09 Mar 2005
Posts: 35
Location: Mysore

PostPosted: Wed Jun 08, 2005 7:59 pm    Post subject:
Reply with quote

Thanks for the info. The job is scheduled to run in small intervals and it FTP?s the file created by another job which also run?s at the same time, but is EXCLUSIVE-CONTROL with the main job. Can you see fault in this, other than FTP connection failure?

___________
GM
Back to top
View user's profile Send private message
MGIndaco

Active User


Joined: 10 Mar 2005
Posts: 432
Location: Milan, Italy

PostPosted: Wed Jun 08, 2005 9:03 pm    Post subject:
Reply with quote

Uhm....
I've some questions for you:
1) is your mainframe partitioned? if is true, the two submit are executed in the same partition?
2) can you see after column 72 if, in instream data, you have dirty characters?
3) how many connection support your server at a time?
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> JCL & VSAM All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts DB2 Program abending without giving a... rahulgarg14 DB2 7 Mon May 29, 2017 8:10 pm
No new posts Getting error while opening a variabl... apandey1 COBOL Programming 5 Fri May 05, 2017 12:22 pm
No new posts IDC2902I Error tzeche ABENDS & Debugging 2 Tue Mar 28, 2017 11:39 am
No new posts Need help with below DB2 error ashek15 DB2 3 Sat Mar 18, 2017 5:56 am
No new posts FINDREP Syntax Error seahawk789 DFSORT/ICETOOL 4 Thu Mar 09, 2017 10:11 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us