Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

Migration under Enterprize PLI. Error handling stoped functi

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> ABENDS & Debugging
View previous topic :: :: View next topic  
Author Message
Evgeny

New User


Joined: 09 Aug 2007
Posts: 2
Location: IBA

PostPosted: Thu Aug 09, 2007 4:27 pm    Post subject: Migration under Enterprize PLI. Error handling stoped functi
Reply with quote

Hello L&G.
Could you please help us to solve the following problem:
We are migrating our application (Mainframe PL/I and ASM) under Enterprise PL/I for z/OS V3.R5.M0. Product identifier version 5655-H31.

We found, that Error Handling process stopped working in correct way after the migration. In brief, On Error Block, defined in several programs upper to the module, that has "signal error" statement, does not receive the control as expected. And the whole application fails with U4091 abend therefore. Assembler parts are involved in between the PL/I program, where "On error" block is described, and PL/I program that calls it.

We would be grateful if anybody of you could tell us, where to find the description of changes, that were made within LE Enterprise version, (especially related to the Dynamic Storage Area), that could result in such an error.

P.S. Trying to simulate this problem on a primitive level of code was not successful. We consider that the complexity of programs could also be the case here. Together with the compiler options used...

Many thanks in advance.
Back to top
View user's profile Send private message

dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Thu Aug 09, 2007 10:15 pm    Post subject:
Reply with quote

Hello Evgeny and welcome to the forums,

As you are in the middle of an upgrade, i expect that if you opened a trouble call with IBM, they would be quite responsive.
Back to top
View user's profile Send private message
Evgeny

New User


Joined: 09 Aug 2007
Posts: 2
Location: IBA

PostPosted: Fri Aug 10, 2007 1:45 pm    Post subject:
Reply with quote

Many thanks for the advice. I will follow it as well.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> ABENDS & Debugging All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts OO COBOL compile error Virendra Shambharkar COBOL Programming 3 Tue Jan 10, 2017 6:05 pm
No new posts S922 Error yuvan ABENDS & Debugging 3 Fri Dec 02, 2016 6:58 pm
No new posts Invoke Webservice Fails with DFHPI100... divated CICS 2 Thu Nov 24, 2016 5:57 pm
No new posts Error during restore rename archanamuthukrishnan All Other Mainframe Topics 2 Fri Oct 14, 2016 3:30 pm
No new posts Error IEC161I 052(009,XXXRS00)-084 wh... amitc23 JCL & VSAM 10 Wed Oct 12, 2016 5:00 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us