Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

CTG 7.0 Windows - connection to the CICS TS z/os version2.2

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> CICS
View previous topic :: :: View next topic  
Author Message
ramco_sita

New User


Joined: 25 Jun 2007
Posts: 40
Location: chennai

PostPosted: Tue Jun 26, 2007 3:28 pm    Post subject: CTG 7.0 Windows - connection to the CICS TS z/os version2.2
Reply with quote

I need help on configuring my CTG to communicate to the CICS TS on mainframe (Z/OS).
I have installed the CTG 7.0 on Windows.
How do i Test my connectivity with the CTG Emulator.
Back to top
View user's profile Send private message

Nimesh.Srivastava

New User


Joined: 30 Nov 2006
Posts: 78
Location: SINGAPORE

PostPosted: Tue Jun 26, 2007 5:30 pm    Post subject:
Reply with quote

Which protocol you want to utilize for connectivity to CICS on mainframe. The sample ctg.ini supplied with the installation would have one for each. Or you can create one with "Configuration Tool" that comes with CUC 7.0.
Once you have the ctg.ini in place then you can test the connectivity with the corresponding server using the following commands
Setting the connection with the server
cicscli /s=SERVER NAME

checking the connection is initiated
cicscli /l
it would say something like connection with server<SERVER NAME> is available

Thanks
Nimesh
Back to top
View user's profile Send private message
ramco_sita

New User


Joined: 25 Jun 2007
Posts: 40
Location: chennai

PostPosted: Tue Jul 03, 2007 3:09 pm    Post subject: CTG Client daemon connection to CICS trn server on z/os test
Reply with quote

I am trying to connect using CTG 7.0 windows version
using the command cicscli /s=server name
when i use this command it tells me that CTG client dameon for this server has been started
after few minutes i get an error message saying
The client daemon is using the following servers:
servername <using TCPIP to ip address> is unavailable
Please some one help me on this.
I am using VPN connection to connect to the mainframe server.
I am told that the port has been open for inbound and outbound for my communication...
Back to top
View user's profile Send private message
pingte

Active User


Joined: 03 Dec 2005
Posts: 120
Location: india

PostPosted: Wed Jul 25, 2007 11:18 am    Post subject:
Reply with quote

First i think u should check on mainframes.. whether TCP/IP port is enabled or not!
And if u r using win XP .. better shift to windows 2000 Advanced server..
I faced similiar problem...
A shift in OS solved it!
Back to top
View user's profile Send private message
ramco_sita

New User


Joined: 25 Jun 2007
Posts: 40
Location: chennai

PostPosted: Tue Jul 31, 2007 10:00 am    Post subject:
Reply with quote

Hi Pingte

We have resolved this problem...

Thanks for your information.

Both side the port has to be opened and listerner program has to be installed and started on the mainframe.

Thanks!
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> CICS All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts CICS Transaction Timeout Hooman24 CICS 2 Sun Apr 16, 2017 2:16 pm
No new posts Date and time format in CICS Chandru3183 CICS 2 Sat Mar 18, 2017 12:46 pm
No new posts Asynchronous CICS Processing Question moezbud CICS 1 Mon Mar 06, 2017 6:13 pm
No new posts CICS Question RE: Browse, Readnext an... moezbud CICS 7 Sun Mar 05, 2017 5:45 am
No new posts how to send just 10 rows in a CICS sc... Megha Gupta CICS 5 Thu Feb 23, 2017 6:57 pm


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us