Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

ABEND=S000 U0210

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> ABENDS & Debugging
View previous topic :: :: View next topic  
Author Message
appu.venkat

New User


Joined: 29 Jan 2007
Posts: 22
Location: India

PostPosted: Thu Feb 22, 2007 6:00 pm    Post subject: ABEND=S000 U0210
Reply with quote

Hi All,

May i know what this abend code refers to??
ABEND=S000 U0210
Back to top
View user's profile Send private message

William Thompson

Global Moderator


Joined: 18 Nov 2006
Posts: 3158
Location: Tucson AZ

PostPosted: Thu Feb 22, 2007 6:05 pm    Post subject:
Reply with quote

May we know a little more information?
Something issued a User abend 210, that is all that can be said without knowing who or why.
Back to top
View user's profile Send private message
appu.venkat

New User


Joined: 29 Jan 2007
Posts: 22
Location: India

PostPosted: Thu Feb 22, 2007 7:32 pm    Post subject:
Reply with quote

The JCL i was trying to compile issused this abend code.What other information do u need?All i could get from the spool was this.It said ABEND=S000 U0210 REASON=00000000.It also says not enough core to load model.
Back to top
View user's profile Send private message
UmeySan

Active Member


Joined: 22 Aug 2006
Posts: 743
Location: Germany

PostPosted: Thu Feb 22, 2007 8:06 pm    Post subject:
Reply with quote

Hi !

>> The JCL i was trying to compile issused this abend code <<

What does that relly mean ???

>> enough core <<

Try REGION=0M in JobCard.

Regards, UmeySan
Back to top
View user's profile Send private message
appu.venkat

New User


Joined: 29 Jan 2007
Posts: 22
Location: India

PostPosted: Fri Feb 23, 2007 10:25 am    Post subject:
Reply with quote

Thanks a lot...This works!!
Back to top
View user's profile Send private message
appu.venkat

New User


Joined: 29 Jan 2007
Posts: 22
Location: India

PostPosted: Fri Feb 23, 2007 10:31 am    Post subject:
Reply with quote

No actually...i compiled the wrong JCL this doesnt work....
Back to top
View user's profile Send private message
appu.venkat

New User


Joined: 29 Jan 2007
Posts: 22
Location: India

PostPosted: Fri Feb 23, 2007 10:36 am    Post subject:
Reply with quote

My COBOL Program has 29 calls to the same subroutine.When i execute the JCL it gives me an abend ABEND=S000 U0210 REASON=00000000 and in the spool i can see a message which says not enough core.May i know wat can be done.This is because amongst the 29 calls there is one member which occupies more space...If i remove that particular member it works fine.But with that it gives me an abend sayin not enough core to load member.How much space shoud i allocate in the JCL??
Back to top
View user's profile Send private message
dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Fri Feb 23, 2007 10:25 pm    Post subject:
Reply with quote

Hello,

Look in your output and you will see how much memory was used. Then specify a larger amount on the REGION= parameter. Bill's recommendatoin to use REGION=0M usually works. . . . icon_confused.gif It may not work because of the way the program processes, it may take an infinite amount of memory and will abend regardless of the size you specify - it would just take longer to abend. . . .

What does "there is one member which occupies more space" mean? What kind of member? What does remove that particular member mean?

Are there 29 call statements or 1 call that may be executed 29 times?

It sounds more like a program logic problem more than anything else.
Back to top
View user's profile Send private message
appu.venkat

New User


Joined: 29 Jan 2007
Posts: 22
Location: India

PostPosted: Mon Feb 26, 2007 11:03 am    Post subject:
Reply with quote

I gave a REGION=3M.It works!!Thanks a lot
Back to top
View user's profile Send private message
dick scherrer

Site Director


Joined: 23 Nov 2006
Posts: 19270
Location: Inside the Matrix

PostPosted: Mon Feb 26, 2007 8:45 pm    Post subject:
Reply with quote

You're welcome. Thank you for posting that it now works icon_smile.gif
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> ABENDS & Debugging All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts IMS BMP program causes 878 system abend Artemk IMS DB/DC 7 Tue Nov 22, 2016 8:26 pm
No new posts abend sort based on count records in ... anatol DFSORT/ICETOOL 5 Mon Oct 17, 2016 10:10 pm
No new posts hot to get details when "EXEC CI... Andi1982 CICS 11 Tue Sep 20, 2016 5:01 pm
No new posts S213-14 ABEND explantion Apurva Mehta JCL & VSAM 5 Thu Jul 07, 2016 10:56 pm
No new posts How to determine where is error in ab... jackzhang75 PL/I & Assembler 13 Fri Apr 15, 2016 2:01 am


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us