Portal | Manuals | References | Downloads | Info | Programs | JCLs | Master the Mainframes
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Usergroups Profile Log in to check your private messages Log in
 

 

Why F all is not working on JES2 Spool

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> TSO/ISPF
View previous topic :: :: View next topic  
Author Message
sweetselva

New User


Joined: 17 Dec 2006
Posts: 4
Location: USA

PostPosted: Tue Dec 19, 2006 7:58 am    Post subject: Why F all is not working on JES2 Spool
Reply with quote

Hi,

Why F all is not working on JES2? I could use F all in JES3.
But it is not working on JES2.

Let me know if anyone knows to make it work.
Back to top
View user's profile Send private message

shrinivas_3
Warnings : 1

New User


Joined: 05 Sep 2006
Posts: 34

PostPosted: Tue Dec 19, 2006 12:37 pm    Post subject: Re: F all in JES2 spool
Reply with quote

sweetselva wrote:
Hi,

Why F all is not working on JES2? I could use F all in JES3.
But it is not working on JES2.

Let me know if anyone knows to make it work.


Hi

suppose you want to search the first occurance on a string say

'ASSIGN' then in jes you have to type

F 'ASSIGN' ALL


then it gives the first occurance of string 'ASSIGN'

the 'ALL' has to be AFTER the string to be searched.

In my shop it works ... check it out and let me know if i am correct.

Thanks
Shrinivas D
Back to top
View user's profile Send private message
shreevamsi

Active User


Joined: 23 Feb 2006
Posts: 305
Location: Hyderabad,India

PostPosted: Tue Dec 19, 2006 6:44 pm    Post subject: Re: Why F all is not working on JES2 Spool
Reply with quote

Hi,

What ever may be JES2 or JES3, Open the SPOOL with option 'SE' and find your required string.
This should solve your problem

~Vamsi
Back to top
View user's profile Send private message
sweetselva

New User


Joined: 17 Dec 2006
Posts: 4
Location: USA

PostPosted: Tue Dec 19, 2006 10:13 pm    Post subject:
Reply with quote

F string ALL works for me. Thanks very much

Thanks
Selva
Back to top
View user's profile Send private message
Karthikeyan J

New User


Joined: 19 Dec 2006
Posts: 16
Location: Mumbai

PostPosted: Thu Dec 21, 2006 1:01 pm    Post subject: SE option too works fine
Reply with quote

Thanks Vamshi,

The SE option too works fine.
Back to top
View user's profile Send private message
Shrimathi Krishnan

New User


Joined: 19 Apr 2007
Posts: 39
Location: Chennai

PostPosted: Thu Apr 19, 2007 5:58 pm    Post subject: Re: Why F all is not working on JES2 Spool
Reply with quote

can u please explain me what is SE option is? can u also tell me how to use it?
Back to top
View user's profile Send private message
guptae

Moderator


Joined: 14 Oct 2005
Posts: 1187
Location: Bangalore,India

PostPosted: Thu Apr 19, 2007 6:02 pm    Post subject:
Reply with quote

Hi Shrimathi,

SE is open it in edit mode
U have to just give SE besides like
Code:

NP   DDNAME   StepName ProcStep
SE   SYSPRINT STEP1    LKED   
Back to top
View user's profile Send private message
ofer71

Global Moderator


Joined: 27 Dec 2005
Posts: 2360
Location: Israel

PostPosted: Thu Apr 19, 2007 6:25 pm    Post subject:
Reply with quote

When you type 'S' - you invoke SDSF BROWSE utility, which is pretty limited.
SE opend the data using ISPF edit command (which actually the EDIF service).

By the way, it has nothing to do with JES - it's stricly SDSF.

O.
Back to top
View user's profile Send private message
enrico-sorichetti

Global Moderator


Joined: 14 Mar 2007
Posts: 10256
Location: italy

PostPosted: Thu Apr 19, 2007 6:30 pm    Post subject: Re: Why F all is not working on JES2 Spool
Reply with quote

Quote:

Hi,

Why F all is not working on JES2? I could use F all in JES3.
But it is not working on JES2.

Let me know if anyone knows to make it work.


Everybody has answered about ispf sdsf find command;

maybe You were referring to the mvs modify command ???

a well posed question is half answered
Back to top
View user's profile Send private message
Phrzby Phil

Active Member


Joined: 31 Oct 2006
Posts: 962
Location: Richmond, Virginia

PostPosted: Thu Apr 19, 2007 9:49 pm    Post subject:
Reply with quote

Don't forget SJ - submitted JCL only, sans proc expansions, but including inline data.
Back to top
View user's profile Send private message
Shrimathi Krishnan

New User


Joined: 19 Apr 2007
Posts: 39
Location: Chennai

PostPosted: Fri Apr 20, 2007 11:16 am    Post subject:
Reply with quote

Thanks a lot buddies!!! icon_smile.gif
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> TSO/ISPF All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
This topic is locked: you cannot edit posts or make replies. SDSF multiple spool datasets extracte... PJAlarcon CLIST & REXX 1 Fri Apr 21, 2017 10:50 pm
No new posts REXX cdoe to purge a JOB from spool a... Sulabh Agrawal CLIST & REXX 11 Thu Mar 09, 2017 11:36 am
No new posts SQL query not working in Cobol program. CuriousMainframer COBOL Programming 14 Wed Feb 22, 2017 5:56 pm
No new posts JES2 JEC: Use UNIX Pipes to Pass Data... Virendra Shambharkar JCL & VSAM 21 Tue Dec 20, 2016 6:55 pm
No new posts How to download JES2 JOB LOG? White.Bai JCL & VSAM 9 Thu Sep 29, 2016 7:34 am


Facebook
Back to Top
 
Mainframe Wiki | Forum Rules | Bookmarks | Subscriptions | FAQ | Tutorials | Contact Us