Portal | Manuals | References | Downloads | Info | Programs | JCLs | Mainframe wiki | Quick Ref
IBM Mainframe Computers Forums Index
 
Register
 
IBM Mainframe Computers Forums Index Mainframe: Search IBM Mainframe Forum: FAQ Memberlist Profile Log in to check your private messages Log in
 
CA 11 - restart after a JCL error

 
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> CA Products
View previous topic :: :: View next topic  
Author Message
Saikia

New User


Joined: 07 Aug 2006
Posts: 3

PostPosted: Mon Aug 07, 2006 8:44 pm    Post subject: CA 11 - restart after a JCL error
Reply with quote

I had a very wierd situation recently. A job was submitted by CA 11 scheduler. Before the CMT table is built, the job went down with JCL error. The job was than submitted again with 'R' processing. As a result, the job picked (-1) gen of any GDG rather than (+0) gen. If the CMT table was not built, why would it make a difference if you are doing a 'R' or a 'P' or a 'F' processing? In this instance, it is clear that in very reference of +0, the job picked up -1. Why would it do that?

Any help is appreciated
Back to top
View user's profile Send private message

Rupesh.Kothari

Member of the Month


Joined: 27 Apr 2005
Posts: 464

PostPosted: Tue Aug 08, 2006 10:24 am    Post subject: Re: CA 11 - restart after a JCL error
Reply with quote

HI,

As per my understanding, In CA11, whenever a job is abendeed and when we restatr the job using CA11, it is using the same file with generation as used in previous abended job.

So in your case, the job abended say G0002V00 and when u restart it again at that time the G0003V00 generated, but you job pick G0002V00 only.

Hope its clear now.

Thanks & regards
Rupesh
Back to top
View user's profile Send private message
Saikia

New User


Joined: 07 Aug 2006
Posts: 3

PostPosted: Tue Aug 08, 2006 7:08 pm    Post subject:
Reply with quote

Actually, in my case, I wanted the job to use G0002V00. But on restart (after it had JCL error), the job ended up using G0001V00. Now, the JCL error came at the very start of the job - similar to JCL error you will get when you use a invalid storage unit. This means that RMS step did not run, and from that I assume that CMT table did not get created. So, when the job was restarted, it almost seem like CA 11 assumed that I am attempting a re-run of the previous day's job (this job runs daily). And since it assumes it is a previous day's run, it started using G0001V00 ! Of course, this is my thought - not sure if I am right or wrong.
Back to top
View user's profile Send private message
Saikia

New User


Joined: 07 Aug 2006
Posts: 3

PostPosted: Wed Aug 09, 2006 11:51 pm    Post subject:
Reply with quote

How about someone help me answer this: At the end of successful completion of a job, does the CMT table get deleted? Or does it stay as it is until the next run, and it gets modified at that time?
Back to top
View user's profile Send private message
SreekanthK
Warnings : 1

New User


Joined: 09 Feb 2007
Posts: 4
Location: Hyderabd

PostPosted: Wed Feb 21, 2007 12:35 pm    Post subject: CA11 restart
Reply with quote

If the RMS step itself got abended then you need to restart the job from the top.

Please let me know if it not clear.
Back to top
View user's profile Send private message
SreekanthK
Warnings : 1

New User


Joined: 09 Feb 2007
Posts: 4
Location: Hyderabd

PostPosted: Wed Feb 21, 2007 12:42 pm    Post subject: Re: CA11 restart
Reply with quote

SreekanthK wrote:
If the job got abended at the RMS step itself then you need to restart the job from the top. We kow that the RMS step will be the first step in the JCL.

Please let me know if it not clear.
Back to top
View user's profile Send private message
View previous topic :: :: View next topic  
Post new topic   Reply to topic    IBMMAINFRAMES.com Support Forums -> CA Products All times are GMT + 6 Hours
Page 1 of 1

 

Search our Forum:

Similar Topics
Topic Author Forum Replies Posted
No new posts Control-M restart instruction sonaliingle CA Products 2 Tue Nov 28, 2017 5:05 pm
No new posts -502 Error - Cursor already open anand jeyapaul DB2 7 Sun Oct 29, 2017 4:22 am
No new posts IEW2456E error when link-editing a C ... Senthilraj JCL & VSAM 0 Fri Oct 13, 2017 3:12 pm
No new posts FTP Skip or ignore error and process ... AJAYREDDY All Other Mainframe Topics 3 Wed Sep 27, 2017 8:12 pm
No new posts Assembler Macro Copybook converted to... Ziquilix PL/I & Assembler 4 Tue Sep 26, 2017 3:07 am

Facebook
Back to Top
 
Job Vacancies | Forum Rules | Bookmarks | Subscriptions | FAQ | Polls | Contact Us